build: add opkg host dependency
authorFelix Fietkau <nbd@openwrt.org>
Sun, 13 Dec 2015 17:03:40 +0000 (17:03 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 13 Dec 2015 17:03:40 +0000 (17:03 +0000)
fixes a missing host opkg
found by: unselect base-files, opkg

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
SVN-Revision: 47885

package/Makefile

index cc691b5ad2080e19ee74f5f614aa13f46ca8dd18..aa5d52251625a4b7a2febe351e3d0e5f3c4cea7a 100644 (file)
@@ -91,7 +91,7 @@ PACKAGE_INSTALL_FILES:= \
 $(curdir)/cleanup: $(TMP_DIR)/.build
        rm -rf $(STAGING_DIR_ROOT)
 
-$(curdir)/install: $(TMP_DIR)/.build
+$(curdir)/install: $(TMP_DIR)/.build $(curdir)/system/opkg/host/install
        - find $(STAGING_DIR_ROOT) -type d | $(XARGS) chmod 0755
        rm -rf $(TARGET_DIR)
        [ -d $(TARGET_DIR)/tmp ] || mkdir -p $(TARGET_DIR)/tmp