octeon: re-enable CONFIG_CAVIUM_CN63XXP1 and EdgeRouter image
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 26 Feb 2021 13:11:18 +0000 (14:11 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 28 Feb 2021 20:55:22 +0000 (21:55 +0100)
The symbol CONFIG_CAVIUM_CN63XXP1 was disabled during the bump to
4.19 (see Fixes:) with the following reason:

  No supported hardware uses CN63XXP1 and it causes "slight decrease
  in performance"

However, it later turned out that the edgerouter image needed it,
which led to having the device disabled in [1].
Still, dropping support of a device seems a harsh action for just
removing a "slight" decrease in performance from the other devices.

Thus, this enables CONFIG_CAVIUM_CN63XXP1 again, and essentially
restores the situation present until (including) kernel 4.14 on
this target.

For OpenWrt as a platform, it seems more desirable to support all
devices (and have them tested regularly via the snapshots) in this
case.
Users interested in maximum performance might still just remove
the symbol again in their local build.

[1] 3824fa26d256 ("octeon: disable edgerouter image")

Fixes: 6c22545225cd ("target/octeon: Add Linux 4.19 support")
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/octeon/config-5.4
target/linux/octeon/image/Makefile

index 30c84b08eb6c418e2266edce60eb4cd5228565fa..b00f89b4512dcc55de8abac21617f68d07ec43bf 100644 (file)
@@ -13,7 +13,7 @@ CONFIG_BLK_DEV_SD=y
 CONFIG_BLK_MQ_PCI=y
 CONFIG_BLK_SCSI_REQUEST=y
 CONFIG_BUILTIN_DTB=y
-# CONFIG_CAVIUM_CN63XXP1 is not set
+CONFIG_CAVIUM_CN63XXP1=y
 CONFIG_CAVIUM_OCTEON_CVMSEG_SIZE=0
 CONFIG_CAVIUM_OCTEON_LOCK_L2=y
 CONFIG_CAVIUM_OCTEON_LOCK_L2_EXCEPTION=y
index 8e97280479d89e0053b081c25acc198e0f0504b3..11da22df3bd49f467e2fba5e7da59d807cefe766 100644 (file)
@@ -48,7 +48,6 @@ define Device/ubnt_edgerouter
   DEVICE_MODEL := EdgeRouter
   BOARD_NAME := er
   CMDLINE := $(ER_CMDLINE)
-  DEFAULT := n
 endef
 TARGET_DEVICES += ubnt_edgerouter