bcm53xx: build images for Luxul ABR-4500 and XBR-4500 routers
authorDan Haab <dan.haab@legrand.com>
Wed, 5 Feb 2020 17:37:44 +0000 (10:37 -0700)
committerRafał Miłecki <rafal@milecki.pl>
Fri, 7 Feb 2020 11:09:27 +0000 (12:09 +0100)
Luxul ABR-4500 and XBR-4500 devices are wired routers with 5 Ethernet
ports and 1 USB 3.0 port. Flashing requires using Luxul firmware 6.4.0
or newer and uploading firmware using "Firmware Update" web UI page.

Signed-off-by: Dan Haab <dan.haab@legrand.com>
(cherry picked from commit 1d47f81581bcd476487e5b29314602167a843b99)
[rmilecki: use DEVICE_TITLE for 19.07]
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
target/linux/bcm53xx/base-files/etc/board.d/02_network
target/linux/bcm53xx/image/Makefile

index 8c9e8b3f3f4e928b37c74cc36d4754fe2297fb9b..9fd26e72f4d08798bb2f197956f44cbf2d0623ba 100755 (executable)
@@ -24,6 +24,13 @@ buffalo,wzr-1750dhp)
        board_config_flush
        exit 0
        ;;
+luxul,abr-4500-v1|\
+luxul,xbr-4500-v1)
+       ucidef_add_switch "switch0" \
+               "0:wan" "1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1" "5@eth0"
+       board_config_flush
+       exit 0
+       ;;
 phicomm,k3)
        ucidef_add_switch "switch0" \
                "0:lan" "1:lan" "2:lan" "3:wan" "5@eth0"
index fc18a96232a0ecfc6583a15f06fc3f6425f1c9e1..4f18a9c0a8b8feea906da62010c7ab7be071b633 100644 (file)
@@ -83,6 +83,13 @@ define Build/asus-trx
        mv $@.new $@
 endef
 
+define Build/luxul-lxl
+       $(STAGING_DIR_HOST)/bin/lxlfw create $@.new \
+               -i $@ \
+               -b $(LUXUL_BOARD)
+       mv $@.new $@
+endef
+
 define Build/seama-nand
        # Seama entity
        $(STAGING_DIR_HOST)/bin/oseama \
@@ -102,6 +109,7 @@ endef
 
 DEVICE_VARS += PRODUCTID SIGNATURE NETGEAR_BOARD_ID NETGEAR_REGION TPLINK_BOARD
 DEVICE_VARS += BUFFALO_TAG_PLATFORM BUFFALO_TAG_VERSION BUFFALO_TAG_MINOR
+DEVICE_VARS += LUXUL_BOARD
 
 IEEE8021X := wpad-basic
 B43 := $(IEEE8021X) kmod-b43
@@ -249,6 +257,27 @@ define Device/linksys-ea9500
 endef
 # TARGET_DEVICES += linksys-ea9500
 
+define Device/luxul
+  IMAGES := lxl
+  IMAGE/lxl := append-ubi | trx-nand | luxul-lxl
+endef
+
+define Device/luxul-abr-4500
+  $(Device/luxul)
+  DEVICE_TITLE := Luxul ABR-4500
+  DEVICE_PACKAGES := $(USB3_PACKAGES)
+  LUXUL_BOARD := ABR-4500
+endef
+TARGET_DEVICES += luxul-abr-4500
+
+define Device/luxul-xbr-4500
+  $(Device/luxul)
+  DEVICE_TITLE := Luxul XBR-4500
+  DEVICE_PACKAGES := $(USB3_PACKAGES)
+  LUXUL_BOARD := XBR-4500
+endef
+TARGET_DEVICES += luxul-xbr-4500
+
 define Device/netgear
   IMAGES := chk
   IMAGE/chk := append-ubi | trx-nand | netgear-chk