make sure a predefined CFLAGS variable does not get in the way (fix for #4038)
authorFelix Fietkau <nbd@openwrt.org>
Thu, 25 Sep 2008 14:10:04 +0000 (14:10 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 25 Sep 2008 14:10:04 +0000 (14:10 +0000)
SVN-Revision: 12702

include/toplevel.mk

index 06b005568ee7058204c5918abeff1243d6b3fe67..9d0eb2593356c80d1cd45a455fef2cb96bda4325 100644 (file)
@@ -24,6 +24,9 @@ export REVISION
 export OPENWRTVERSION
 export IS_TTY=$(shell tty -s && echo 1 || echo 0)
 
+# make sure that a predefined CFLAGS variable does not disturb packages
+export CFLAGS=
+
 ifeq ($(FORCE),)
   .config scripts/config/conf scripts/config/mconf: tmp/.prereq-build
 endif