kernel: bump 4.14 to 4.14.53
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 4 Jul 2018 09:54:47 +0000 (11:54 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 4 Jul 2018 12:16:37 +0000 (14:16 +0200)
Refreshed all patches

Compile-tested on: cns3xxx, imx6, x86_64
Runtime-tested on: cns3xxx, imx6, x86_64

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/pending-4.14/490-ubi-auto-attach-mtd-device-named-ubi-or-data-on-boot.patch
target/linux/ipq40xx/patches-4.14/400-mtd-ubi-add-quirk-to-autoload-ubi-on-rt-ac58u.patch
target/linux/mediatek/patches-4.14/0064-dts.patch
target/linux/mediatek/patches-4.14/0225-arm-dts-Add-missing-mt7623-pcie-nodes.patch

index 48c284c6fd276b26fa8eabdfd9862fcc131b0546..d580cd1ae4bb87bfbd60b63bd7ca21cc2316a907 100644 (file)
@@ -4,13 +4,13 @@ LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .71
 LINUX_VERSION-4.4 = .121
 
 LINUX_VERSION-3.18 = .71
 LINUX_VERSION-4.4 = .121
-LINUX_VERSION-4.14 = .52
 LINUX_VERSION-4.9 = .111
 LINUX_VERSION-4.9 = .111
+LINUX_VERSION-4.14 = .53
 
 LINUX_KERNEL_HASH-3.18.71 = 5abc9778ad44ce02ed6c8ab52ece8a21c6d20d21f6ed8a19287b4a38a50c1240
 LINUX_KERNEL_HASH-4.4.121 = 44a88268b5088dc326b30c9b9133ac35a9a200b636b7268d08f32abeae6ca729
 
 LINUX_KERNEL_HASH-3.18.71 = 5abc9778ad44ce02ed6c8ab52ece8a21c6d20d21f6ed8a19287b4a38a50c1240
 LINUX_KERNEL_HASH-4.4.121 = 44a88268b5088dc326b30c9b9133ac35a9a200b636b7268d08f32abeae6ca729
-LINUX_KERNEL_HASH-4.14.52 = a5d226c7b2fd1eb0f01d56e4e2c6a0100784b68df907cc7317f32bde34f88810
 LINUX_KERNEL_HASH-4.9.111 = 5966558959dc580f163766f3fdefd7e57c01b2b45d51202d00b3807c253759dd
 LINUX_KERNEL_HASH-4.9.111 = 5966558959dc580f163766f3fdefd7e57c01b2b45d51202d00b3807c253759dd
+LINUX_KERNEL_HASH-4.14.53 = a85f2572f97dc551f4a159d0c0858e6f40b925afd2d14a0aa25ee9238da80bbf
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 2a09caf442548b4d4f5d6d9aeaffc0dc109451de..63afabb1d96893205af5aad4c5c7b7ecd1e96504 100644 (file)
@@ -8,7 +8,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
 
 --- a/drivers/mtd/ubi/build.c
 +++ b/drivers/mtd/ubi/build.c
 
 --- a/drivers/mtd/ubi/build.c
 +++ b/drivers/mtd/ubi/build.c
-@@ -1168,6 +1168,49 @@ static struct mtd_info * __init open_mtd
+@@ -1171,6 +1171,49 @@ static struct mtd_info * __init open_mtd
        return mtd;
  }
  
        return mtd;
  }
  
@@ -58,7 +58,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  static int __init ubi_init(void)
  {
        int err, i, k;
  static int __init ubi_init(void)
  {
        int err, i, k;
-@@ -1251,6 +1294,12 @@ static int __init ubi_init(void)
+@@ -1254,6 +1297,12 @@ static int __init ubi_init(void)
                }
        }
  
                }
        }
  
index 8a9da2c0881353f359f102dfd6deed647f66e565..4ee79515c9a8dac1c635d7e57565ec5edea6e8ef 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
 
 --- a/drivers/mtd/ubi/build.c
 +++ b/drivers/mtd/ubi/build.c
 
 --- a/drivers/mtd/ubi/build.c
 +++ b/drivers/mtd/ubi/build.c
-@@ -1181,6 +1181,9 @@ static void __init ubi_auto_attach(void)
+@@ -1184,6 +1184,9 @@ static void __init ubi_auto_attach(void)
        mtd = open_mtd_device("ubi");
        if (IS_ERR(mtd))
                mtd = open_mtd_device("data");
        mtd = open_mtd_device("ubi");
        if (IS_ERR(mtd))
                mtd = open_mtd_device("data");
index cfae4fee64a4c8ff62205abb3384cbdda61aca3a..08feb8d731e86b9afd959917e21e6b867e8edb46 100644 (file)
@@ -11,8 +11,8 @@
        cpus {
                cpu@0 {
                        proc-supply = <&mt6323_vproc_reg>;
        cpus {
                cpu@0 {
                        proc-supply = <&mt6323_vproc_reg>;
-@@ -102,6 +106,10 @@
-       memory@80000000 {
+@@ -103,6 +107,10 @@
+               device_type = "memory";
                reg = <0 0x80000000 0 0x40000000>;
        };
 +
                reg = <0 0x80000000 0 0x40000000>;
        };
 +
@@ -22,7 +22,7 @@
  };
  
  &cir {
  };
  
  &cir {
-@@ -129,11 +137,24 @@
+@@ -130,11 +138,24 @@
                };
        };
  
                };
        };
  
@@ -49,7 +49,7 @@
                        compatible = "mediatek,mt7530";
                        #address-cells = <1>;
                        #size-cells = <0>;
                        compatible = "mediatek,mt7530";
                        #address-cells = <1>;
                        #size-cells = <0>;
-@@ -143,6 +164,8 @@
+@@ -144,6 +165,8 @@
                        core-supply = <&mt6323_vpa_reg>;
                        io-supply = <&mt6323_vemc3v3_reg>;
  
                        core-supply = <&mt6323_vpa_reg>;
                        io-supply = <&mt6323_vemc3v3_reg>;
  
@@ -58,7 +58,7 @@
                        ports {
                                #address-cells = <1>;
                                #size-cells = <0>;
                        ports {
                                #address-cells = <1>;
                                #size-cells = <0>;
-@@ -151,29 +174,46 @@
+@@ -152,29 +175,46 @@
                                port@0 {
                                        reg = <0>;
                                        label = "wan";
                                port@0 {
                                        reg = <0>;
                                        label = "wan";
                                        reg = <6>;
                                        label = "cpu";
                                        ethernet = <&gmac0>;
                                        reg = <6>;
                                        label = "cpu";
                                        ethernet = <&gmac0>;
-@@ -186,8 +226,6 @@
+@@ -187,8 +227,6 @@
                                };
                        };
                };
                                };
                        };
                };
 +
 --- a/arch/arm/boot/dts/mt7623.dtsi
 +++ b/arch/arm/boot/dts/mt7623.dtsi
 +
 --- a/arch/arm/boot/dts/mt7623.dtsi
 +++ b/arch/arm/boot/dts/mt7623.dtsi
-@@ -322,6 +322,7 @@
+@@ -323,6 +323,7 @@
                             "syscon";
                reg = <0 0x10209000 0 0x1000>;
                #clock-cells = <1>;
                             "syscon";
                reg = <0 0x10209000 0 0x1000>;
                #clock-cells = <1>;
index 6e94015dc545c22e96a57476ee055f8527611b87..68dd23bdb964f57f731493d77f1f4aa1c7933ec6 100644 (file)
@@ -9,7 +9,7 @@ Subject: [PATCH] arm: dts: Add missing mt7623 pcie nodes
 
 --- a/arch/arm/boot/dts/mt7623.dtsi
 +++ b/arch/arm/boot/dts/mt7623.dtsi
 
 --- a/arch/arm/boot/dts/mt7623.dtsi
 +++ b/arch/arm/boot/dts/mt7623.dtsi
-@@ -670,6 +670,111 @@
+@@ -671,6 +671,111 @@
                #reset-cells = <1>;
        };
  
                #reset-cells = <1>;
        };