sdk: bundle usbip userspace sources
authorJo-Philipp Wich <jo@mein.io>
Wed, 1 Aug 2018 07:11:17 +0000 (09:11 +0200)
committerJo-Philipp Wich <jo@mein.io>
Wed, 1 Aug 2018 07:12:17 +0000 (09:12 +0200)
Bundle the usbip utility sources shipped with the Linux kernel tree in
order to allow the usbip packages from the package feed to build within
the OpenWrt SDK.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
target/sdk/Makefile

index d3822a0df60bb4aa8c3d285a24253aebc1482a9f..499c2809dd2c3c1e18367b8a61fde4dfdc1a0abd 100644 (file)
@@ -84,6 +84,10 @@ $(BIN_DIR)/$(SDK_NAME).tar.xz: clean
                $(SDK_DIRS) $(KERNEL_FILES) | \
                $(TAR) -xf - -C $(SDK_BUILD_DIR)
 
+       # Copy usbip sources, this is required for the usbip userspace packages to be buildable by the SDK.
+       $(TAR) -cf - -C $(TOPDIR) $(KDIR_BASE)/tools/usb/usbip/ | \
+               $(TAR) -xf - -C $(SDK_BUILD_DIR)
+
        (cd $(SDK_BUILD_DIR); find $(STAGING_SUBDIR_HOST)/bin $(STAGING_SUBDIR_HOST)/usr/bin \
                $(STAGING_SUBDIR_TOOLCHAIN)/bin $(STAGING_SUBDIR_TOOLCHAIN)/*/bin $(STAGING_SUBDIR_TOOLCHAIN)/libexec \
                -type f | $(XARGS) $(SCRIPT_DIR)/bundle-libraries.sh $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_HOST))