ramips: add support for TP-Link TL-WR902AC v3
authorPeter Lundkvist <peter.lundkvist@gmail.com>
Sat, 17 Mar 2018 17:47:51 +0000 (18:47 +0100)
committerMathias Kresin <dev@kresin.me>
Sun, 18 Mar 2018 21:22:38 +0000 (22:22 +0100)
TP-Link TL-WR902AC v3 is a pocket-size dual-band (AC750) router
based on MediaTek MT7628N + MT7650E.

Specification:
- MediaTek MT7628N/N (580 Mhz)
- 64 MB of RAM
- 8 MB of FLASH
- 2T2R 2.4 GHz and 1T1R 5 GHz
- 1x 10/100 Mbps Ethernet

* MT7650 ac chip isn't not supported by LEDE/OpenWrt at the moment.
  Therefore 5Ghz won' work.

Flash instruction:

The only way to flash LEDE image in TL-WR902AC v3 is to use
tftp recovery mode in U-Boot:

1. Configure PC with static IP 192.168.0.66/24 and tftp server.
2. Rename "openwrt-ramips-mt76x8-tplink_tl-wr902ac-v3-squashfs-tftp-recovery.bin"
   to "tp_recovery.bin" and place it in tftp server directory.
3. Connect PC with the LAN port, press the reset button, power up
   the router and keep button pressed for around 6-7 seconds, until
   device starts downloading the file.
4. Router will download file from server, write it to flash and reboot.

Signed-off-by: Peter Lundkvist <peter.lundkvist@gmail.com>
[drop p2led_an pinmux, this pin isn't used as gpio, fix whitespace issues]
Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/TL-WR902ACV3.dts [new file with mode: 0644]
target/linux/ramips/image/mt76x8.mk

index b068e62e87161dcdc6b28d3f2f6367f87cd440d8..4b8242cb9fe3a16e970653006d0a6bc7dbc042b4 100755 (executable)
@@ -414,6 +414,11 @@ tplink,tl-mr3420-v5)
        ucidef_set_led_switch "lan" "lan" "$boardname:green:lan" "switch0" "0x1e"
        ucidef_set_led_switch "wan" "wan" "$boardname:green:wan" "switch0" "0x01"
        ;;
+tplink,tl-wr902ac-v3)
+       set_usb_led "$boardname:green:usb"
+       ucidef_set_led_netdev "wlan2g" "wlan2g" "$boardname:green:wlan" "wlan0"
+       ucidef_set_led_switch "lan" "lan" "$boardname:green:lan" "switch0" "0x10"
+       ;;
 u25awf-h1)
        set_wifi_led "u25awf:red:wifi"
        ucidef_set_led_netdev "eth" "eth" "u25awf:green:lan" "eth0"
index d20b0aa1aa0213bd08ec29d27257b6ad7beac17e..03f718ee30fbd42e80b08643dccd0fcfebd3a543 100755 (executable)
@@ -320,6 +320,10 @@ ramips_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "1:lan" "2:lan" "3:lan" "4:lan" "5:wan" "0@eth0"
                ;;
+       tplink,tl-wr902ac-v3)
+               ucidef_add_switch "switch0" \
+                       "4:lan" "6@eth0"
+               ;;
        vonets,var11n-300|\
        wt1520-4M|\
        wt1520-8M)
index 2dcc75a019543dcf24bfdb6d3d65920de445a8d1..d9f131b2a819a397feb072c6c550d06111442ea2 100644 (file)
@@ -41,6 +41,7 @@ get_status_led() {
        tplink,c20-v4|\
        tplink,c50-v3|\
        tplink,tl-mr3420-v5|\
+       tplink,tl-wr902ac-v3|\
        tl-wr840n-v4|\
        tl-wr840n-v5|\
        tl-wr841n-v13|\
index e6489a2b5802d9b2298edb7e9a89423e4cfdf7e8..b052cf8625610b6dfbdd7341ee156101abc2b576 100755 (executable)
@@ -250,6 +250,7 @@ platform_check_image() {
        tplink,c20-v4|\
        tplink,c50-v3|\
        tplink,tl-mr3420-v5|\
+       tplink,tl-wr902ac-v3|\
        tl-wr840n-v4|\
        tl-wr840n-v5|\
        tl-wr841n-v13)
diff --git a/target/linux/ramips/dts/TL-WR902ACV3.dts b/target/linux/ramips/dts/TL-WR902ACV3.dts
new file mode 100644 (file)
index 0000000..8ff3576
--- /dev/null
@@ -0,0 +1,102 @@
+/dts-v1/;
+
+#include "TPLINK-8M.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       compatible = "tplink,tl-wr902ac-v3", "mediatek,mt7628an-soc";
+       model = "TP-Link TL-WR902AC v3";
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio1 6 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+
+               sw1 {
+                       label = "sw1";
+                       gpios = <&gpio0 2 GPIO_ACTIVE_LOW>;
+                       linux,code = <BTN_0>;
+               };
+
+               sw2 {
+                       label = "sw2";
+                       gpios = <&gpio0 3 GPIO_ACTIVE_LOW>;
+                       linux,code = <BTN_1>;
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               lan {
+                       label = "tl-wr902ac-v3:green:lan";
+                       gpios = <&gpio0 5 GPIO_ACTIVE_HIGH>;
+               };
+
+               power {
+                       label = "tl-wr902ac-v3:green:power";
+                       gpios = <&gpio1 14 GPIO_ACTIVE_LOW>;
+               };
+
+               usb {
+                       label = "tl-wr902ac-v3:green:usb";
+                       gpios = <&gpio1 11 GPIO_ACTIVE_LOW>;
+               };
+
+               wan {
+                       label = "tl-wr902ac-v3:green:wan";
+                       gpios = <&gpio1 7 GPIO_ACTIVE_LOW>;
+               };
+
+               wlan {
+                       label = "tl-wr902ac-v3:green:wlan";
+                       gpios = <&gpio1 12 GPIO_ACTIVE_LOW>;
+               };
+
+               wps {
+                       label = "tl-wr902ac-v3:green:wps";
+                       gpios = <&gpio0 4 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&pinctrl {
+       state_default: pinctrl0 {
+               gpio {
+                       ralink,group = "i2c", "i2s", "p0led_an", "p4led_an", "uart1", "wdt", "wled_an";
+                       ralink,function = "gpio";
+               };
+       };
+};
+
+&ehci {
+       status = "okay";
+};
+
+&ohci {
+       status = "okay";
+};
+
+&pcie {
+       status = "okay";
+
+       pcie-bridge {
+               mt76@1,0 {
+                       reg = <0x0000 0 0 0 0>;
+                       device_type = "pci";
+                       mediatek,mtd-eeprom = <&factory 0x28000>;
+                       ieee80211-freq-limit = <5000000 6000000>;
+                       mtd-mac-address = <&factory 0xf100>;
+                       mtd-mac-address-increment = <(-1)>;
+               };
+       };
+};
index bcee98ef453b4cf50b89b8ef3c564292cfe94b6a..4362c3bc433ffda8d1b197772bf3088a4cd65b95 100644 (file)
@@ -196,6 +196,21 @@ define Device/tplink_tl-mr3420-v5
 endef
 TARGET_DEVICES += tplink_tl-mr3420-v5
 
+define Device/tplink_tl-wr902ac-v3
+  $(Device/tplink)
+  DTS := TL-WR902ACV3
+  IMAGE_SIZE := 7808k
+  DEVICE_TITLE := TP-Link TL-WR902AC v3
+  TPLINK_FLASHLAYOUT := 8Mmtk
+  TPLINK_HWID := 0x000dc88f
+  TPLINK_HWREV := 0x89
+  TPLINK_HWREVADD := 0x1
+  TPLINK_HVERSION := 3
+  IMAGES += factory.bin
+  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += tplink_tl-wr902ac-v3
+
 define Device/u7628-01-128M-16M
   DTS := U7628-01-128M-16M
   IMAGE_SIZE := 16064k