ramips: enable flashing WizFi630S via OEM firmware
authorTobias Welz <tw@wiznet.eu>
Mon, 3 Aug 2020 19:28:31 +0000 (21:28 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 8 Aug 2020 14:36:24 +0000 (16:36 +0200)
WIZnet WizFi630s board name is written slightly different it its OEM
OpenWrt firmware. This causes an incompatibility warning during flashing
with sysupgrade. This patch is adding the vendor board name to the
supported devices list to avoid this warning. For initial flashing you
can use sysupgrade via command line or luci beside of TFTP.
Do not keep the OEM configuration during sysupgrade.

Signed-off-by: Tobias Welz <tw@wiznet.eu>
(cherry picked from commit 816973f42aa47d910d3e35c2f8f8eb9d67416396)

target/linux/ramips/image/mt76x8.mk

index 7df5c04297693263098549d445ece3fed5d9aba0..d0c66a0e234cde08eb9ff0240f2297178040362e 100644 (file)
@@ -440,6 +440,7 @@ define Device/wiznet_wizfi630s
   DTS := WIZFI630S
   IMAGE_SIZE := $(ralink_default_fw_size_32M)
   DEVICE_TITLE := WIZnet WizFi630S
+  SUPPORTED_DEVICES += wizfi630s
 endef
 TARGET_DEVICES += wiznet_wizfi630s