opkg: fix PKG_CONFIG_DEPENDS to include version.mk entries
authorRafał Miłecki <rafal@milecki.pl>
Thu, 14 Dec 2017 08:39:18 +0000 (09:39 +0100)
committerJohn Crispin <john@phrozen.org>
Thu, 14 Dec 2017 08:39:40 +0000 (09:39 +0100)
Including version.mk sets PKG_CONFIG_DEPENDS to config entries used for
VERSION_SED command. We should keep these configs to make sure package
gets refreshed when needed.

Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
package/system/opkg/Makefile

index 7b49a3b..76557f3 100644 (file)
@@ -23,7 +23,8 @@ PKG_LICENSE_FILES:=COPYING
 
 PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
 
-PKG_CONFIG_DEPENDS := \
+# Extend depends from version.mk
+PKG_CONFIG_DEPENDS += \
        CONFIG_SIGNED_PACKAGES \
        CONFIG_TARGET_INIT_PATH