package/busybox: make PAM support depend on DEVEL (closes: #8002 & #8743)
authorNicolas Thill <nico@openwrt.org>
Mon, 24 Oct 2011 08:18:33 +0000 (08:18 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 24 Oct 2011 08:18:33 +0000 (08:18 +0000)
SVN-Revision: 28549

package/busybox/config/loginutils/Config.in

index c6e50bd..94bf32b 100644 (file)
@@ -219,10 +219,15 @@ config BUSYBOX_CONFIG_LOGIN
 config BUSYBOX_CONFIG_PAM
        bool "Support for PAM (Pluggable Authentication Modules)"
        default n
+       depends on DEVEL
        depends on BUSYBOX_CONFIG_LOGIN
        help
          Use PAM in login(1) instead of direct access to password database.
 
+         OpenWrt specific:
+           You should install libpam from the packages feed and compile it
+           before trying to build busysbox.
+
 config BUSYBOX_CONFIG_LOGIN_SCRIPTS
        bool "Support for login scripts"
        depends on BUSYBOX_CONFIG_LOGIN