rename PATCH to KPATCH
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 7 Oct 2010 11:32:09 +0000 (11:32 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 7 Oct 2010 11:32:09 +0000 (11:32 +0000)
SVN-Revision: 23286

include/quilt.mk
rules.mk

index 6c4839ba4ac324efc5f226e03c9bf548c6fb8572..9309fc94b76f27719d239d07f7187b7daa84b4f9 100644 (file)
@@ -42,9 +42,9 @@ define PatchDir/Default
        @if [ -d "$(2)" -a "$$$$(ls $(2) | wc -l)" -gt 0 ]; then \
                if [ -s "$(2)/series" ]; then \
                        $(call filter_series,$(2)/series) | xargs -n1 \
        @if [ -d "$(2)" -a "$$$$(ls $(2) | wc -l)" -gt 0 ]; then \
                if [ -s "$(2)/series" ]; then \
                        $(call filter_series,$(2)/series) | xargs -n1 \
-                               $(PATCH) "$(1)" "$(2)"; \
+                               $(KPATCH) "$(1)" "$(2)"; \
                else \
                else \
-                       $(PATCH) "$(1)" "$(2)"; \
+                       $(KPATCH) "$(1)" "$(2)"; \
                fi; \
        fi
 endef
                fi; \
        fi
 endef
index c0004d808832ae3a2c85a7c94efe44a5affac1c9..49044c8cfbf4b87a8468742d4cb8abe51d62d4d9 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -160,7 +160,7 @@ HOST_LDFLAGS:=-L$(STAGING_DIR_HOST)/lib
 
 TARGET_CC:=$(TARGET_CROSS)gcc
 TARGET_CXX:=$(if $(CONFIG_INSTALL_LIBSTDCPP),$(TARGET_CROSS)g++,no)
 
 TARGET_CC:=$(TARGET_CROSS)gcc
 TARGET_CXX:=$(if $(CONFIG_INSTALL_LIBSTDCPP),$(TARGET_CROSS)g++,no)
-PATCH:=$(SCRIPT_DIR)/patch-kernel.sh
+KPATCH:=$(SCRIPT_DIR)/patch-kernel.sh
 SED:=$(STAGING_DIR_HOST)/bin/sed -i -e
 CP:=cp -fpR
 LN:=ln -sf
 SED:=$(STAGING_DIR_HOST)/bin/sed -i -e
 CP:=cp -fpR
 LN:=ln -sf