swconfig: libsw.so should be installed into /usr/lib/
authorJohn Crispin <john@openwrt.org>
Fri, 17 Jul 2015 12:51:24 +0000 (12:51 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 17 Jul 2015 12:51:24 +0000 (12:51 +0000)
otherwise it's not picked up by toolchain:

staging_dir/toolchain-mipsel_24kec+dsp_gcc-4.8-linaro_musl-1.1.10/lib/gcc/mipsel-openwrt-linux-musl/4.8.3/../../../../mipsel-openwrt-linux-musl/bin/ld: cannot find -lsw

Signed-off-by: Roman Yeryomin <roman@advem.lv>
SVN-Revision: 46406

package/network/config/swconfig/Makefile

index 3c2ec3e387860ff797c10fdcfb1ebd64b2880e87..b62b059873ba49fa55d9a13db551fb4949cac41c 100644 (file)
@@ -46,8 +46,8 @@ define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_BUILD_DIR)/swlib.h $(1)/usr/include/
 
-       $(INSTALL_DIR) $(1)/lib
-       $(CP) $(PKG_BUILD_DIR)/libsw.so $(1)/lib/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/libsw.so $(1)/usr/lib/
 endef
 
 define Package/swconfig/install