Revert "tools/cmake: Update to 3.14.0"
authorStijn Tintel <stijn@linux-ipv6.be>
Sun, 17 Mar 2019 10:17:28 +0000 (11:17 +0100)
committerStijn Tintel <stijn@linux-ipv6.be>
Sun, 17 Mar 2019 10:25:50 +0000 (11:25 +0100)
The cmake bump to 3.14.0 breaks build on all targets. Revert it for now.

This reverts commit a3446257a8737bfc2899c5911791873561feecc7.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
tools/cmake/Makefile
tools/cmake/patches/100-disable_qt_tests.patch
tools/cmake/patches/120-curl-fix-libressl-linking.patch
tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
tools/cmake/patches/150-C-feature-checks-Match-warnings-more-strictly.patch [new file with mode: 0644]

index 4a33e7b0ed624ea80aab50956b5e03960dc60027..888cf7de8e28bc10c41b152f3dd75dfb084d3081 100644 (file)
@@ -7,13 +7,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cmake
-PKG_VERSION:=3.14.0
+PKG_VERSION:=3.13.2
 PKG_CPE_ID:=cpe:/a:kitware:cmake
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://cmake.org/files/v3.14/ \
-               https://github.com/Kitware/CMake/releases/download/v$(PKG_VERSION)/
-PKG_HASH:=aa76ba67b3c2af1946701f847073f4652af5cbd9f141f221c97af99127e75502
+PKG_SOURCE_URL:=https://cmake.org/files/v3.13/ \
+               https://fossies.org/linux/misc/
+PKG_HASH:=c925e7d2c5ba511a69f43543ed7b4182a7d446c274c7480d0e42cd933076ae25
 
 HOST_BUILD_PARALLEL:=1
 HOST_CONFIGURE_PARALLEL:=1
index 7f83e279f73996f2bb245777224235f8f4f8069c..af04bf7c4198c2d1ac04684f17adfc8bc05ef3d5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Tests/RunCMake/CMakeLists.txt
 +++ b/Tests/RunCMake/CMakeLists.txt
-@@ -325,15 +325,6 @@ add_RunCMake_test(no_install_prefix)
+@@ -301,15 +301,6 @@ add_RunCMake_test(no_install_prefix)
  add_RunCMake_test(configure_file)
  add_RunCMake_test(CTestTimeoutAfterMatch)
  
@@ -18,7 +18,7 @@
    add_RunCMake_test(FindPkgConfig)
 --- a/Tests/CMakeLists.txt
 +++ b/Tests/CMakeLists.txt
-@@ -483,13 +483,6 @@ if(BUILD_TESTING)
+@@ -437,13 +437,6 @@ if(BUILD_TESTING)
  
    list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
  
index e7d9c5ddda665d89cf937aaa51d6b24b8f2dacef..e217979ee42f2f61d020462758d29e7d829bbcd8 100644 (file)
@@ -20,7 +20,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
 ---
 --- a/Utilities/cmcurl/CMakeLists.txt
 +++ b/Utilities/cmcurl/CMakeLists.txt
-@@ -453,6 +453,14 @@ if(CMAKE_USE_OPENSSL)
+@@ -454,6 +454,14 @@ if(CMAKE_USE_OPENSSL)
    set(USE_OPENSSL ON)
    set(HAVE_LIBCRYPTO ON)
    set(HAVE_LIBSSL ON)
index 124cf6d9d42240edf24ab438f604664a3008d363..535417d55a69949d2d4e0a8252e101d6928b4619 100644 (file)
@@ -1,6 +1,6 @@
 --- a/bootstrap
 +++ b/bootstrap
-@@ -1168,7 +1168,10 @@ int main(){ printf("1%c", (char)0x0a); r
+@@ -1164,7 +1164,10 @@ int main(){ printf("1%c", (char)0x0a); r
  ' > "test.c"
  cmake_original_make_flags="${cmake_make_flags}"
  if [ "x${cmake_parallel_make}" != "x" ]; then
diff --git a/tools/cmake/patches/150-C-feature-checks-Match-warnings-more-strictly.patch b/tools/cmake/patches/150-C-feature-checks-Match-warnings-more-strictly.patch
new file mode 100644 (file)
index 0000000..674ff0d
--- /dev/null
@@ -0,0 +1,25 @@
+From 4ca5a815f2dfe9e1116cc2ccd5ddb56d0d00d12e Mon Sep 17 00:00:00 2001
+From: Brad King <brad.king@kitware.com>
+Date: Thu, 7 Mar 2019 14:55:54 -0500
+Subject: [PATCH] C++ feature checks: Match warnings more strictly
+
+Require the word "warning" to appear at the start of a line, after
+whitespace, or after a `:`.  This is the same that CTest launchers use
+to match warnings.  It avoids matching "warning" inside file paths.
+
+Fixes: #19019
+---
+ Source/Checks/cm_cxx_features.cmake | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/Source/Checks/cm_cxx_features.cmake
++++ b/Source/Checks/cm_cxx_features.cmake
+@@ -25,7 +25,7 @@ function(cm_check_cxx_feature name)
+     # Filter out xcodebuild warnings.
+     string(REGEX REPLACE "[^\n]* xcodebuild\\[[0-9]*:[0-9]*\\] warning: [^\n]*" "" check_output "${check_output}")
+     # If using the feature causes warnings, treat it as broken/unavailable.
+-    if(check_output MATCHES "[Ww]arning")
++    if(check_output MATCHES "(^|[ :])[Ww][Aa][Rr][Nn][Ii][Nn][Gg]")
+       set(CMake_HAVE_CXX_${FEATURE} OFF CACHE INTERNAL "TRY_COMPILE" FORCE)
+     endif()
+     if(CMake_HAVE_CXX_${FEATURE})