linux-firmware: add a new package for firmware (currently only builds r8169 firmware)
authorFelix Fietkau <nbd@openwrt.org>
Thu, 10 Apr 2014 14:43:30 +0000 (14:43 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 10 Apr 2014 14:43:30 +0000 (14:43 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 40447

package/firmware/linux-firmware/Makefile [new file with mode: 0644]

diff --git a/package/firmware/linux-firmware/Makefile b/package/firmware/linux-firmware/Makefile
new file mode 100644 (file)
index 0000000..fdc7de1
--- /dev/null
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=linux-firmware
+PKG_SOURCE_VERSION:=f8c22c692bdee57a20b092e647464ff6176df3ed
+PKG_VERSION:=2014-03-16-$(PKG_SOURCE_VERSION)
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git
+PKG_MIRROR_MD5SUM:=ca4d289ad9380471cae376fc7dd3660a
+
+PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/r8169-firmware
+  SECTION:=firmware
+  CATEGORY:=Firmware
+  URL:=http://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git
+  TITLE:=RealTek r8169 firmware
+endef
+
+define Build/Compile
+
+endef
+
+define Package/r8169-firmware/install
+       $(INSTALL_DIR) $(1)/lib/firmware/rtl_nic
+       $(CP) \
+               $(PKG_BUILD_DIR)/rtl_nic/* \
+               $(1)/lib/firmware/rtl_nic
+endef
+
+$(eval $(call BuildPackage,r8169-firmware))