sunxi: add support for Sinovoip Banana Pi M2 Plus
authorPawel Dembicki <paweldembicki@gmail.com>
Fri, 15 Feb 2019 15:08:53 +0000 (16:08 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 17 Feb 2019 18:22:39 +0000 (19:22 +0100)
CPU: H3 Quad-core Cortex-A7 H.265/HEVC 4K @ 1.2 Ghz
GPU: Mali400MP2 GPU @ 600MHz (supports OpenGL ES 2.0)
Memory: 1GB DDR3 (shared with GPU)
Onboard: Storage TF card (Max. 64GB) / MMC card slot
Onboard: Network 10/100M Ethernet RJ45 (Realtek RTL8211E)
Onboard: Network BT4.0/WiFi 802.11 b/g/n (Ampak AP6212)
Onboard header: SPI, I2C, GPIO, UART
USB 2.0: Two USB 2.0 HOST, One USB 2.0 OTG

Untested:
Audio, Video

Not working:
Bluetooth

Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
package/boot/uboot-sunxi/Makefile
target/linux/sunxi/base-files/lib/firmware/brcm/brcmfmac43430a0-sdio.txt [new symlink]
target/linux/sunxi/image/cortex-a7.mk

index 59aa4f0277e3fe66f1c3a8a7e8d4ac5415296564..1d920507c7b8fd5a3731172008d3bb44182a5537 100644 (file)
@@ -204,6 +204,12 @@ define U-Boot/pine64_plus
   UENV:=a64
 endef
 
   UENV:=a64
 endef
 
+define U-Boot/Sinovoip_BPI_M2_Plus
+  BUILD_SUBTARGET:=cortexa7
+  NAME:=Bananapi M2 Plus
+  BUILD_DEVICES:=sun8i-h3-bananapi-m2-plus
+endef
+
 define U-Boot/sopine_baseboard
   BUILD_SUBTARGET:=cortexa53
   NAME:=Sopine Baseboard
 define U-Boot/sopine_baseboard
   BUILD_SUBTARGET:=cortexa53
   NAME:=Sopine Baseboard
@@ -260,6 +266,7 @@ UBOOT_TARGETS := \
        orangepi_pc2 \
        pangolin \
        pine64_plus \
        orangepi_pc2 \
        pangolin \
        pine64_plus \
+       Sinovoip_BPI_M2_Plus \
        sopine_baseboard \
        orangepi_zero_plus
 
        sopine_baseboard \
        orangepi_zero_plus
 
diff --git a/target/linux/sunxi/base-files/lib/firmware/brcm/brcmfmac43430a0-sdio.txt b/target/linux/sunxi/base-files/lib/firmware/brcm/brcmfmac43430a0-sdio.txt
new file mode 120000 (symlink)
index 0000000..2ed6689
--- /dev/null
@@ -0,0 +1 @@
+brcmfmac43430-sdio.txt
\ No newline at end of file
index 969864bb766ab3f3d51865115908686baa1ffbdf..58c3b6fc40c75e564054e50af57bc273ddc55a40 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2013-2016 OpenWrt.org
+# Copyright (C) 2013-2019 OpenWrt.org
 # Copyright (C) 2016 Yousong Zhou
 #
 # This is free software, licensed under the GNU General Public License v2.
 # Copyright (C) 2016 Yousong Zhou
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -127,6 +127,16 @@ endef
 
 TARGET_DEVICES += sun8i-h2-plus-orangepi-r1
 
 
 TARGET_DEVICES += sun8i-h2-plus-orangepi-r1
 
+define Device/sun8i-h3-bananapi-m2-plus
+  DEVICE_TITLE:=Sinovoip Banana Pi M2 Plus
+  DEVICE_PACKAGES:=kmod-rtc-sunxi \
+       kmod-leds-gpio kmod-ledtrig-heartbeat \
+       kmod-brcmfmac brcmfmac-firmware-43430a0-sdio wpad-basic
+  SUPPORTED_DEVICES:=sinovoip,bananapi-m2-plus
+  SUNXI_DTS:=sun8i-h3-bananapi-m2-plus
+endef
+
+TARGET_DEVICES += sun8i-h3-bananapi-m2-plus
 
 define Device/sun8i-h3-nanopi-m1-plus
   DEVICE_TITLE:=FriendlyArm NanoPi M1 Plus
 
 define Device/sun8i-h3-nanopi-m1-plus
   DEVICE_TITLE:=FriendlyArm NanoPi M1 Plus