tools/zlib: switch to configure script
authorRosen Penev <rosenp@gmail.com>
Sun, 25 Sep 2022 07:22:24 +0000 (00:22 -0700)
committerChristian Marangi <ansuelsmth@gmail.com>
Thu, 29 Sep 2022 17:33:13 +0000 (19:33 +0200)
A future commit will make tools/cmake use this.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
tools/Makefile
tools/zlib/Makefile

index 5b7eaf8cd37520a707aa4563cf26447b1c0393e4..ae1c3ded85e3595d0f6308b0da723f89df7c0c1f 100644 (file)
@@ -75,7 +75,6 @@ $(curdir)/quilt/compile := $(curdir)/autoconf/compile $(curdir)/findutils/compil
 $(curdir)/sdcc/compile := $(curdir)/bison/compile
 $(curdir)/squashfs/compile := $(curdir)/lzma-old/compile
 $(curdir)/squashfskit4/compile := $(curdir)/xz/compile $(curdir)/zlib/compile
-$(curdir)/zlib/compile := $(curdir)/cmake/compile
 $(curdir)/zstd/compile := $(curdir)/meson/compile
 
 ifneq ($(HOST_OS),Linux)
@@ -92,7 +91,7 @@ else
 endif
 
 ifneq ($(CONFIG_CCACHE)$(CONFIG_SDK),)
-$(foreach tool, $(filter-out xz zstd pkgconf patch ninja meson libressl cmake,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/compile))
+$(foreach tool, $(filter-out zstd zlib xz pkgconf patch ninja meson libressl cmake,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/compile))
 tools-y += ccache
 $(curdir)/ccache/compile := $(curdir)/cmake/compile $(curdir)/zstd/compile
 endif
index 58315b8083aa13c5672aef1ab5ce79939b93623c..974de3815463b792ac1273ef48b53a676e9494ab 100644 (file)
@@ -20,23 +20,23 @@ PKG_LICENSE:=Zlib
 PKG_LICENSE_FILES:=README
 PKG_CPE_ID:=cpe:/a:gnu:zlib
 
+HOST_BUILD_PARALLEL:=1
+
 include $(INCLUDE_DIR)/host-build.mk
-include $(INCLUDE_DIR)/cmake.mk
 
-HOST_CFLAGS +=-fPIC
+HOSTCC := $(HOSTCC_NOCACHE)
+HOST_CFLAGS += $(HOST_FPIC)
 
-define Host/Install
-       $(CP) $(HOST_BUILD_DIR)/libz.a $(STAGING_DIR_HOST)/lib/
-       $(CP) $(HOST_BUILD_DIR)/zconf.h $(STAGING_DIR_HOST)/include/
-       $(CP) $(HOST_BUILD_DIR)/zlib.h $(STAGING_DIR_HOST)/include/
-       $(CP) $(HOST_BUILD_DIR)/zlib.pc $(STAGING_DIR_HOST)/lib/pkgconfig/
-endef
+HOST_CONFIGURE_ARGS = \
+       --prefix=$(STAGING_DIR_HOST) \
+       --sysconfdir=$(STAGING_DIR_HOST)/etc \
+       --localstatedir=$(STAGING_DIR_HOST)/var \
+       --libdir=$(STAGING_DIR_HOST)/lib \
+       --includedir=$(STAGING_DIR_HOST)/include \
+       --static
 
-define Host/Clean
-       rm -f $(STAGING_DIR_HOST)/lib/libz.a
-       rm -f $(STAGING_DIR_HOST)/include/zconf.h
-       rm -f $(STAGING_DIR_HOST)/include/zlib.h
-       rm -f $(STAGING_DIR_HOST)/lib/pkgconfig//zlib.pc
+define Host/Uninstall
+       -$(call Host/Compile/Default,uninstall)
 endef
 
 $(eval $(call HostBuild))