pxcab: Replace TARGET_pxcab with feature powerpc64
authorGeoff Levand <geoffrey.levand@am.sony.com>
Tue, 18 Aug 2009 23:09:50 +0000 (23:09 +0000)
committerGeoff Levand <geoffrey.levand@am.sony.com>
Tue, 18 Aug 2009 23:09:50 +0000 (23:09 +0000)
Signed-off-by: Geoff Levand <geoffrey.levand@am.sony.com>
SVN-Revision: 17307

target/linux/pxcab/Makefile
toolchain/Config.in
toolchain/gcc/Config.in
toolchain/gcc/Config.version

index 62289851bf1c58e442045965b13488f7a3621725..945f3f2d07179b5fd5ddcad2b1ae11dfa7c3b821 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=pxcab
 BOARDNAME:=PowerXCell Accelerator Board
-FEATURES:=fpu ramdisk
+FEATURES+=powerpc64 fpu ramdisk
 
 LINUX_VERSION:=2.6.30.5
 
index f01b6c23b20c9fb4de4c49c65e35410e0d48d987..c7b876b690ae1159be4fe0c0bf4108b7525f71b2 100644 (file)
@@ -13,7 +13,7 @@ menuconfig TOOLCHAINOPTS
 menuconfig EXTRA_TARGET_ARCH
        bool
        prompt "Enable an extra toolchain target architecture" if TOOLCHAINOPTS
-       default y       if powerpc64 || TARGET_pxcab
+       default y       if powerpc64
        default n
        help
          Some builds may require a 'biarch' toolchain. This option
@@ -23,7 +23,7 @@ menuconfig EXTRA_TARGET_ARCH
 
        config EXTRA_TARGET_ARCH_NAME
                string
-               default "powerpc64"     if powerpc64 || TARGET_pxcab
+               default "powerpc64"     if powerpc64
                prompt "Extra architecture name" if EXTRA_TARGET_ARCH
                help
                  Specify the cpu name (eg powerpc64 or x86_64) of the
@@ -31,7 +31,7 @@ menuconfig EXTRA_TARGET_ARCH
 
        config EXTRA_TARGET_ARCH_OPTS
                string
-               default "-m64"          if powerpc64 || TARGET_pxcab
+               default "-m64"          if powerpc64
                prompt "Extra architecture compiler options" if EXTRA_TARGET_ARCH
                help
                  If you're specifying an addition target architecture,
index 6cbf2cdb630a7599b8f7f145519da33bbf55a03c..4148d66197e5097bb16823fedaa799e1ad07b397 100644 (file)
@@ -7,7 +7,6 @@ choice
        default GCC_VERSION_4_2_4 if TARGET_ppc40x
        default GCC_VERSION_4_2_4 if TARGET_ppc44x
        default GCC_VERSION_4_3_3 if powerpc64
-       default GCC_VERSION_4_3_3 if TARGET_pxcab
        default GCC_VERSION_4_3_3 if TARGET_etrax
        default GCC_VERSION_4_3_3 if TARGET_coldfire
        default GCC_VERSION_4_1_2
index 5a0f66887023f2ddbab4859deb3445c0af3d022c..8bd77add55a76061ba0b0edaed78c8432942a1c0 100644 (file)
@@ -53,7 +53,6 @@ if !TOOLCHAINOPTS
 
        config GCC_VERSION_4_3_3
                default y if powerpc64
-               default y if TARGET_pxcab
                default y if TARGET_etrax
                default y if TARGET_coldfire
 endif