ar71xx: fix mtd_layout for the DIR-615-C1 and similar devices
authorGabor Juhos <juhosg@openwrt.org>
Tue, 20 Apr 2010 08:07:25 +0000 (08:07 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Tue, 20 Apr 2010 08:07:25 +0000 (08:07 +0000)
  * Thanks to Yury Polyanskiy for the report

SVN-Revision: 21036

target/linux/ar71xx/image/Makefile

index 1eafa09bdcda7edfc00c151e3d0a662322a9ad3a..cd066f78ed1c2a39a66c46af135baea44a9b7e19 100644 (file)
@@ -127,7 +127,7 @@ define Image/Build/WZRHPG300NH
        fi; fi
 endef
 
-cameo_mtdlayout=mtdparts=spi0.0:128k(u-boot)ro,64k(config)ro,896k(kernel),2880k(rootfs),64k(art)ro,3776k@0x30000(firmware)
+cameo_mtdlayout=mtdparts=spi0.0:128k(u-boot)ro,64k(config)ro,896k(kernel),2944k(rootfs),64k(art)ro,3840k@0x30000(firmware)
 define Image/Build/Cameo
        $(call PatchKernelLzma,$(2),$(3) $(cameo_mtdlayout))
        if [ `stat -c%s "$(KDIR)/vmlinux-$(2).bin.lzma"` -gt 917504 ]; then \