apm821xx: image: add support for k unit suffix to boot-img
authorMathias Kresin <dev@kresin.me>
Thu, 8 Sep 2016 18:14:42 +0000 (20:14 +0200)
committerMathias Kresin <dev@kresin.me>
Thu, 8 Sep 2016 18:14:42 +0000 (20:14 +0200)
Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/apm821xx/image/Makefile

index f151543b9c05f8b33c05c54e44cfb7ce6d1b88bf..38877f9bcaf148a3df9cf0a2a43e2487c3b8cdf7 100644 (file)
@@ -184,7 +184,7 @@ define Build/boot-img
        $(CP) $(IMAGE_KERNEL).dtb $@.bootdir/boot/$(DEVICE_DTB)
        $(CP) $(IMAGE_KERNEL) $@.bootdir/boot/uImage
 
        $(CP) $(IMAGE_KERNEL).dtb $@.bootdir/boot/$(DEVICE_DTB)
        $(CP) $(IMAGE_KERNEL) $@.bootdir/boot/uImage
 
-       genext2fs --block-size $(BLOCKSIZE) --size-in-blocks $$((1024 * $(BOOT_SIZE))) --root $@.bootdir $@.boot
+       genext2fs --block-size $(BLOCKSIZE:%k=%Ki) --size-in-blocks $$((1024 * $(BOOT_SIZE))) --root $@.bootdir $@.boot
 
        # convert it to revision 1 - needed for u-boot ext2load
        $(STAGING_DIR_HOST)/bin/tune2fs -O filetype $@.boot
 
        # convert it to revision 1 - needed for u-boot ext2load
        $(STAGING_DIR_HOST)/bin/tune2fs -O filetype $@.boot