ar71xx: add support for WHQX E1700AC/E600G/E600GAC v2
authorPeng Zhang <sd20@qxwlan.com>
Fri, 5 Jan 2018 09:38:05 +0000 (17:38 +0800)
committerPiotr Dymacz <pepe2k@gmail.com>
Thu, 22 Feb 2018 17:53:22 +0000 (18:53 +0100)
WHQX E1700AC v2 is based on Qualcomm QCA9563 + QCA9880 + QCA8334.

Specification:

- 750/400/250 MHz (CPU/DDR/AHB)
- 128 MB of RAM (DDR2)
- 8/16 MB of FLASH (SPI NOR)
- 3T3R 2.4 GHz (QCA9563) with external FEM (SKY85309-11)
- 3T3R 5 GHz (QCA9880) with external FEM (SKY85728-11)
- 2x 10/100/1000 Mbps Ethernet (one port with PoE support)
- 1x miniPCIe slot (USB 2.0 bus only)
- 1x microSIM slot
- 1x USB 2.0
- 5x LED (4 driven by GPIO)
- 1x button (reset)
- 1x 2-pos switch
- 1x DC jack for main power input (9-48 V)
- UART (J5) and LEDs (J13) headers on PCB

WHQX E600G is based on Qualcomm QCA9531.

Specification:

- 650/391/216 MHz (CPU/DDR/AHB)
- 64/128 MB of RAM (DDR2)
- 8/16 MB of FLASH (SPI NOR)
- 2T2R 2.4 GHz (QCA9531) with external PA (LXK-6601)
- 2x 10/100 Mbps Ethernet (one port with PoE support)
- 1x miniPCIe slot (with PCIe and USB 2.0 buses)
- 1x microSIM slot
- 5x LED (4 driven by GPIO)
- 1x button (reset)
- 1x DC jack for main power input (9-48 V)
- UART (J100), SIM (J34), JTAG (J5) and LEDs (J7) headers on PCB

WHQX E600GAC is based on Qualcomm QCA9531 + QCA9887.

Specification:

- 650/391/216 MHz (CPU/DDR/AHB)
- 64/128 MB of RAM (DDR2)
- 8/16 MB of FLASH (SPI NOR)
- 2T2R 2.4 GHz (QCA9531)
- 1T1R 5 GHz (QCA9887) with external FEM (SKY85703-11)
- 2x 10/100 Mbps Ethernet
- 6x LED (1x RGB, 5 driven by GPIO)
- 1x button (reset)
- 1x DC jack for main power input (9-12 V)
- UART (J100), USB (J102), JTAG (J5) and LEDs (J7) header on PCB

Important notice:

First version of these boards are using different mtd layout, with ART
data at the end. You should not use v2 images on v1 board because it
will result in lost of ART data!

Flash instruction (using U-Boot CLI and tftp server):

1. Configure PC with static IP 192.168.1.10 and tftp server.
2. Rename "sysupgrade" filename to "firmware.bin" and place it in tftp
   server directory.
3. Connect PC with one of RJ45 ports, power up the board and press
   "enter" key to access U-Boot CLI.
4. Use the following command to update the device to OpenWrt: "run lfw".

Flash instruction (using U-Boot web-based recovery):

1. Configure PC with static IP 192.168.1.xxx(2-254)/24.
2. Connect PC with one of RJ45 ports, press the reset button, power up
   the board and keep button pressed for around 6-7 seconds, until LEDs
   start flashing.
3. Open your browser and enter 192.168.1.1, select "sysupgrade" image
   and click the upgrade button.

Signed-off-by: Peng Zhang <sd20@qxwlan.com>
[reworked: image generation code, mach-* files, commit description,
fixed minor code style issues, rebased on master]
Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
15 files changed:
target/linux/ar71xx/base-files/etc/board.d/01_leds
target/linux/ar71xx/base-files/etc/board.d/02_network
target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/config-4.4
target/linux/ar71xx/config-4.9
target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
target/linux/ar71xx/files/arch/mips/ath79/Makefile
target/linux/ar71xx/files/arch/mips/ath79/mach-e1700ac-v2.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ath79/mach-e600g-v2.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
target/linux/ar71xx/generic/config-default
target/linux/ar71xx/image/generic.mk

index 6711fb4ce9aa1fcbc7925e186dfadb04319f411e..725bab2c71d2e9b1c6201e72c065acc5ac040d87 100755 (executable)
@@ -64,7 +64,9 @@ ap90q|\
 cpe505n|\
 cpe830|\
 cpe870|\
-dr531)
+dr531|\
+e600g-v2|\
+e600gac-v2)
        ucidef_set_led_netdev "lan" "LAN" "$board:green:lan" "eth0"
        ucidef_set_led_netdev "wan" "WAN" "$board:green:wan" "eth1"
 
@@ -342,6 +344,10 @@ dlan-pro-1200-ac)
        ucidef_set_led_gpio "plcw" "dLAN" "devolo:status:dlan" "17" "0"
        ucidef_set_led_gpio "plcr" "dLAN" "devolo:error:dlan" "16" "0"
        ;;
+e1700ac-v2)
+       ucidef_set_led_usbdev "usb" "USB" "$board:green:usb" "1-1"
+       ucidef_set_led_wlan "wlan2g" "WLAN2G" "$board:green:wlan2g" "phy1tpt"
+       ;;
 esr900)
        ucidef_set_led_wlan "wlan2g" "WLAN 2.4 GHz" "engenius:blue:wlan-2g" "phy0tpt"
        ucidef_set_led_wlan "wlan5g" "WLAN 5 GHz" "engenius:blue:wlan-5g" "phy1tpt"
index f131b3b633e68f92cfc84adbec0714f45025efe9..0fe71e07606a92684415f8a2630eb3bcfea9e5ea 100755 (executable)
@@ -355,6 +355,12 @@ ar71xx_setup_interfaces()
                        "0u@eth0" "2:lan" "3:lan" "4:lan"
                ucidef_add_switch_attr "switch0" "enable" "false"
                ;;
+       e1700ac-v2|\
+       unifiac-pro|\
+       xd3200)
+               ucidef_add_switch "switch0" \
+                       "0@eth0" "2:lan" "3:wan"
+               ;;
        ebr-2310-c1)
                ucidef_set_interfaces_lan_wan "eth0.1" "eth1"
                ucidef_add_switch "switch0" \
@@ -493,11 +499,6 @@ ar71xx_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0@eth0" "1:lan" "2:wan"
                ;;
-       unifiac-pro|\
-       xd3200)
-               ucidef_add_switch "switch0" \
-                       "0@eth0" "2:lan" "3:wan"
-               ;;
        wndr3700|\
        wndr3700v2|\
        wndr3800|\
index 3b5fc32298420bc15b38fd39309b6e2645279c7a..facc77ee60ff4e3633c36130caa0935bda161373 100644 (file)
@@ -23,6 +23,8 @@ get_status_led() {
        antminer-s1|\
        antminer-s3|\
        antminer-r1|\
+       e1700ac-v2|\
+       e600gac-v2|\
        eap120|\
        minibox-v1|\
        som9331|\
@@ -199,6 +201,9 @@ get_status_led() {
        r36a)
                status_led="$board:blue:status"
                ;;
+       e600g-v2)
+               status_led="$board:blue:system"
+               ;;
        eap300v2)
                status_led="engenius:blue:power"
                ;;
index 8284550e929f099ce90fbc04274313ba46daf094..b0ada3b3423cb856962dea6feaee85aa80ed435b 100644 (file)
@@ -67,6 +67,8 @@ case "$FIRMWARE" in
        cf-e380ac-v1|\
        cf-e380ac-v2|\
        dlan-pro-1200-ac|\
+       e1700ac-v2|\
+       e600gac-v2|\
        sr3200|\
        xd3200)
                ath10kcal_extract "art" 20480 2116
index f0742c1e7b020377cdbd82ecc0e580d019b2a3bb..a9c6821ba85ec51c73c2cae486e88169979406be 100755 (executable)
@@ -627,9 +627,18 @@ ar71xx_board_detect() {
        *"DW33D")
                name="dw33d"
                ;;
+       *"E1700AC v2")
+               name="e1700ac-v2"
+               ;;
        *"E2100L")
                name="e2100l"
                ;;
+       *"E600G v2")
+               name="e600g-v2"
+               ;;
+       *"E600GAC v2")
+               name="e600gac-v2"
+               ;;
        *"EAP120")
                name="eap120"
                tplink_pharos_board_detect
index 88d0f2970a043bc2387d7bd90996b282122673aa..614692d6639eb24f55e520c371f2864b0a82b24d 100755 (executable)
@@ -233,6 +233,9 @@ platform_check_image() {
        dr342|\
        dr531|\
        dragino2|\
+       e1700ac-v2|\
+       e600g-v2|\
+       e600gac-v2|\
        ebr-2310-c1|\
        ens202ext|\
        epg5000|\
index 068b83ce8af8e41ef061f86c4bb629bb0fee9b44..ec398a70719a977c9d3d4ce98dac8ad02bdc0536 100644 (file)
@@ -99,7 +99,9 @@ CONFIG_ATH79=y
 # CONFIG_ATH79_MACH_DR344 is not set
 # CONFIG_ATH79_MACH_DR531 is not set
 # CONFIG_ATH79_MACH_DRAGINO2 is not set
+# CONFIG_ATH79_MACH_E1700AC_V2 is not set
 # CONFIG_ATH79_MACH_E2100L is not set
+# CONFIG_ATH79_MACH_E600G_V2 is not set
 # CONFIG_ATH79_MACH_EAP120 is not set
 # CONFIG_ATH79_MACH_EAP300V2 is not set
 # CONFIG_ATH79_MACH_EAP7660D is not set
index e495f6b4c26da3a8c872056aba15d040a94b7989..924f17cd7189f91c378638c5f6cd3f43bd95f604 100644 (file)
@@ -97,7 +97,9 @@ CONFIG_ATH79=y
 # CONFIG_ATH79_MACH_DR344 is not set
 # CONFIG_ATH79_MACH_DR531 is not set
 # CONFIG_ATH79_MACH_DRAGINO2 is not set
+# CONFIG_ATH79_MACH_E1700AC_V2 is not set
 # CONFIG_ATH79_MACH_E2100L is not set
+# CONFIG_ATH79_MACH_E600G_V2 is not set
 # CONFIG_ATH79_MACH_EAP120 is not set
 # CONFIG_ATH79_MACH_EAP300V2 is not set
 # CONFIG_ATH79_MACH_EAP7660D is not set
index fca5d01b3a379da9cdb1fd6c07977db26e6efe0b..ad4e2a23c68131cac11316448e63afe5f228bf05 100644 (file)
@@ -689,6 +689,17 @@ config ATH79_MACH_DRAGINO2
        select ATH79_DEV_ETH
        select ATH79_DEV_USB
 
+config ATH79_MACH_E1700AC_V2
+       bool "WHQX E1700AC v2 support"
+       select SOC_QCA956X
+       select ATH79_DEV_AP9X_PCI if PCI
+       select ATH79_DEV_ETH
+       select ATH79_DEV_GPIO_BUTTONS
+       select ATH79_DEV_LEDS_GPIO
+       select ATH79_DEV_M25P80
+       select ATH79_DEV_USB
+       select ATH79_DEV_WMAC
+
 config ATH79_MACH_E2100L
        bool "Linksys E2100L board support"
        select SOC_AR913X
@@ -700,6 +711,17 @@ config ATH79_MACH_E2100L
        select ATH79_DEV_WMAC
        select ATH79_NVRAM
 
+config ATH79_MACH_E600G_V2
+       bool "WHQX E600G/E600GAC v2 support"
+       select SOC_QCA953X
+       select ATH79_DEV_AP9X_PCI if PCI
+       select ATH79_DEV_ETH
+       select ATH79_DEV_GPIO_BUTTONS
+       select ATH79_DEV_LEDS_GPIO
+       select ATH79_DEV_M25P80
+       select ATH79_DEV_USB
+       select ATH79_DEV_WMAC
+
 config ATH79_MACH_ESR900
        bool "EnGenius ESR900 board support"
        select SOC_QCA955X
index 98d4677a5f711da6bf6974f54e6ee0e522bd63ed..d489b1a59a93b4acfd8f820dadccf38f1a4bfa69 100644 (file)
@@ -108,6 +108,8 @@ obj-$(CONFIG_ATH79_MACH_DR342)                      += mach-dr344.o
 obj-$(CONFIG_ATH79_MACH_DR344)                 += mach-dr344.o
 obj-$(CONFIG_ATH79_MACH_DR531)                 += mach-dr531.o
 obj-$(CONFIG_ATH79_MACH_DRAGINO2)              += mach-dragino2.o
+obj-$(CONFIG_ATH79_MACH_E1700AC_V2)            += mach-e1700ac-v2.o
+obj-$(CONFIG_ATH79_MACH_E600G_V2)              += mach-e600g-v2.o
 obj-$(CONFIG_ATH79_MACH_EAP120)                        += mach-eap120.o
 obj-$(CONFIG_ATH79_MACH_EAP300V2)              += mach-eap300v2.o
 obj-$(CONFIG_ATH79_MACH_EAP7660D)              += mach-eap7660d.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-e1700ac-v2.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-e1700ac-v2.c
new file mode 100644 (file)
index 0000000..584fd51
--- /dev/null
@@ -0,0 +1,145 @@
+/*
+ *  WHQX E1700AC v2 board support
+ *
+ *  Copyright (C) 2017 Peng Zhang <sd20@qxwlan.com>
+ *  Copyright (C) 2018 Piotr Dymacz <pepe2k@gmail.com>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/platform_device.h>
+#include <linux/ar8216_platform.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+#include "pci.h"
+
+#define E1700AC_V2_GPIO_LED_SYS                1
+#define E1700AC_V2_GPIO_LED_USB                7
+#define E1700AC_V2_GPIO_LED_WLAN2G     19
+
+#define E1700AC_V2_GPIO_BTN_SW1                2
+#define E1700AC_V2_GPIO_BTN_RESET      11
+
+#define E1700AC_V2_KEYS_POLL_INTERVAL          20 /* msecs */
+#define E1700AC_V2_KEYS_DEBOUNCE_INTERVAL      \
+                                       (3 * E1700AC_V2_KEYS_POLL_INTERVAL)
+
+static struct gpio_led e1700ac_v2_leds_gpio[] __initdata = {
+       {
+               .name           = "e1700ac-v2:green:system",
+               .gpio           = E1700AC_V2_GPIO_LED_SYS,
+               .active_low     = 1,
+       }, {
+               .name           = "e1700ac-v2:green:usb",
+               .gpio           = E1700AC_V2_GPIO_LED_USB,
+               .active_low     = 1,
+       }, {
+               .name           = "e1700ac-v2:green:wlan2g",
+               .gpio           = E1700AC_V2_GPIO_LED_WLAN2G,
+               .active_low     = 1,
+       },
+};
+
+static struct gpio_keys_button e1700ac_v2_gpio_keys[] __initdata = {
+       {
+               .desc                   = "reset",
+               .type                   = EV_KEY,
+               .code                   = KEY_RESTART,
+               .debounce_interval      = E1700AC_V2_KEYS_DEBOUNCE_INTERVAL,
+               .gpio                   = E1700AC_V2_GPIO_BTN_RESET,
+               .active_low             = 1,
+       }, {
+               .desc                   = "sw1",
+               .type                   = EV_KEY,
+               .code                   = BTN_0,
+               .debounce_interval      = E1700AC_V2_KEYS_DEBOUNCE_INTERVAL,
+               .gpio                   = E1700AC_V2_GPIO_BTN_SW1,
+               .active_low             = 1,
+       },
+};
+
+static const struct ar8327_led_info e1700ac_v2_leds_qca8334[] = {
+       AR8327_LED_INFO(PHY1_0, HW, "e1700ac-v2:green:lan"),
+       AR8327_LED_INFO(PHY2_0, HW, "e1700ac-v2:green:wan"),
+};
+
+/* Blink rate: 1 Gbps -> 8 hz, 100 Mbs -> 4 Hz, 10 Mbps -> 2 Hz */
+static struct ar8327_led_cfg e1700ac_v2_qca8334_led_cfg = {
+       .led_ctrl0 = 0xcf37cf37,
+       .led_ctrl1 = 0xcf37cf37,
+       .led_ctrl2 = 0xcf37cf37,
+       .led_ctrl3 = 0x0,
+       .open_drain = true,
+};
+
+static struct ar8327_pad_cfg e1700ac_v2_qca8334_pad0_cfg = {
+       .mode = AR8327_PAD_MAC_SGMII,
+       .sgmii_delay_en = true,
+};
+
+static struct ar8327_platform_data e1700ac_v2_qca8334_data = {
+       .pad0_cfg = &e1700ac_v2_qca8334_pad0_cfg,
+       .port0_cfg = {
+               .force_link = 1,
+               .speed = AR8327_PORT_SPEED_1000,
+               .duplex = 1,
+               .txpause = 1,
+               .rxpause = 1,
+       },
+       .led_cfg = &e1700ac_v2_qca8334_led_cfg,
+       .leds = e1700ac_v2_leds_qca8334,
+       .num_leds = ARRAY_SIZE(e1700ac_v2_leds_qca8334),
+};
+
+static struct mdio_board_info e1700ac_v2_mdio0_info[] = {
+       {
+               .bus_id = "ag71xx-mdio.0",
+               .phy_addr = 0,
+               .platform_data = &e1700ac_v2_qca8334_data,
+       },
+};
+
+static void __init e1700ac_v2_setup(void)
+{
+       u8 *mac = (u8 *) KSEG1ADDR(0x1f050400);
+       u8 *art = (u8 *) KSEG1ADDR(0x1f061000);
+
+       ath79_register_m25p80(NULL);
+
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(e1700ac_v2_leds_gpio),
+                                e1700ac_v2_leds_gpio);
+
+       ath79_register_gpio_keys_polled(-1, E1700AC_V2_KEYS_POLL_INTERVAL,
+                                       ARRAY_SIZE(e1700ac_v2_gpio_keys),
+                                       e1700ac_v2_gpio_keys);
+
+       ath79_register_mdio(0, 0x0);
+       mdiobus_register_board_info(e1700ac_v2_mdio0_info,
+                                   ARRAY_SIZE(e1700ac_v2_mdio0_info));
+
+       /* GMAC0 is connected to QCA8334 switch */
+       ath79_eth0_data.duplex = DUPLEX_FULL;
+       ath79_eth0_data.mii_bus_dev = &ath79_mdio0_device.dev;
+       ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_SGMII;
+       ath79_eth0_data.phy_mask = BIT(0);
+       ath79_eth0_data.speed = SPEED_1000;
+       ath79_eth0_pll_data.pll_1000 = 0x03000101;
+       ath79_init_mac(ath79_eth0_data.mac_addr, mac, 0);
+       ath79_register_eth(0);
+
+       ath79_register_pci();
+       ath79_register_usb();
+       ath79_register_wmac(art, NULL);
+}
+
+MIPS_MACHINE(ATH79_MACH_E1700AC_V2, "E1700AC-V2", "WHQX E1700AC v2",
+            e1700ac_v2_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-e600g-v2.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-e600g-v2.c
new file mode 100644 (file)
index 0000000..9838c30
--- /dev/null
@@ -0,0 +1,184 @@
+/*
+ *  WHQX E600G/E600GAC v2 board support
+ *
+ *  Copyright (C) 2017 Peng Zhang <sd20@qxwlan.com>
+ *  Copyright (C) 2018 Piotr Dymacz <pepe2k@gmail.com>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+#include "pci.h"
+
+#define E600G_V2_GPIO_LED_LAN          16
+#define E600G_V2_GPIO_LED_SYS          13
+#define E600G_V2_GPIO_LED_WAN_B                4
+#define E600G_V2_GPIO_LED_WAN_G                15
+
+#define E600GAC_V2_GPIO_LED_CTRL_B     14
+#define E600GAC_V2_GPIO_LED_CTRL_G     11
+#define E600GAC_V2_GPIO_LED_CTRL_R     12
+#define E600GAC_V2_GPIO_LED_LAN                16
+#define E600GAC_V2_GPIO_LED_SYS                13
+#define E600GAC_V2_GPIO_LED_WAN_G      15
+#define E600GAC_V2_GPIO_LED_WAN_O      4
+
+#define E600G_V2_GPIO_BTN_RESET                17
+#define E600GAC_V2_GPIO_BTN_WPS                1
+
+#define E600G_V2_KEYS_POLL_INTERVAL    20 /* msecs */
+#define E600G_V2_KEYS_DEBOUNCE_INTERVAL        (3 * E600G_V2_KEYS_POLL_INTERVAL)
+
+static struct gpio_led e600g_v2_leds_gpio[] __initdata = {
+       {
+               .name           = "e600g-v2:blue:system",
+               .gpio           = E600G_V2_GPIO_LED_SYS,
+               .active_low     = 1,
+       }, {
+               .name           = "e600g-v2:blue:wan",
+               .gpio           = E600G_V2_GPIO_LED_WAN_B,
+               .active_low     = 1,
+       }, {
+               .name           = "e600g-v2:green:lan",
+               .gpio           = E600G_V2_GPIO_LED_LAN,
+               .active_low     = 1,
+       }, {
+               .name           = "e600g-v2:green:wan",
+               .gpio           = E600G_V2_GPIO_LED_WAN_G,
+               .active_low     = 1,
+       },
+};
+
+static struct gpio_led e600gac_v2_leds_gpio[] __initdata = {
+       {
+               .name           = "e600gac-v2:blue:control",
+               .gpio           = E600GAC_V2_GPIO_LED_CTRL_B,
+               .active_low     = 1,
+       }, {
+               .name           = "e600gac-v2:green:control",
+               .gpio           = E600GAC_V2_GPIO_LED_CTRL_G,
+               .active_low     = 1,
+       }, {
+               .name           = "e600gac-v2:red:control",
+               .gpio           = E600GAC_V2_GPIO_LED_CTRL_R,
+               .active_low     = 1,
+       }, {
+               .name           = "e600gac-v2:green:system",
+               .gpio           = E600GAC_V2_GPIO_LED_SYS,
+               .active_low     = 1,
+       }, {
+               .name           = "e600gac-v2:orange:wan",
+               .gpio           = E600GAC_V2_GPIO_LED_WAN_O,
+               .active_low     = 1,
+       }, {
+               .name           = "e600gac-v2:green:lan",
+               .gpio           = E600GAC_V2_GPIO_LED_LAN,
+               .active_low     = 1,
+       }, {
+               .name           = "e600gac-v2:green:wan",
+               .gpio           = E600GAC_V2_GPIO_LED_WAN_G,
+               .active_low     = 1,
+       },
+};
+
+static struct gpio_keys_button e600g_v2_gpio_keys[] __initdata = {
+       {
+               .desc                   = "reset",
+               .type                   = EV_KEY,
+               .code                   = KEY_RESTART,
+               .debounce_interval      = E600G_V2_KEYS_DEBOUNCE_INTERVAL,
+               .gpio                   = E600G_V2_GPIO_BTN_RESET,
+               .active_low             = 1,
+       },
+};
+
+static struct gpio_keys_button e600gac_v2_gpio_keys[] __initdata = {
+       {
+               .desc                   = "reset",
+               .type                   = EV_KEY,
+               .code                   = KEY_RESTART,
+               .debounce_interval      = E600G_V2_KEYS_DEBOUNCE_INTERVAL,
+               .gpio                   = E600G_V2_GPIO_BTN_RESET,
+               .active_low             = 1,
+       }, {
+               .desc                   = "wps",
+               .type                   = EV_KEY,
+               .code                   = KEY_WPS_BUTTON,
+               .debounce_interval      = E600G_V2_KEYS_DEBOUNCE_INTERVAL,
+               .gpio                   = E600GAC_V2_GPIO_BTN_WPS,
+               .active_low             = 1,
+       },
+};
+
+static void __init e600g_v2_common_setup(void)
+{
+       u8 *mac = (u8 *) KSEG1ADDR(0x1f050400);
+       u8 *art = (u8 *) KSEG1ADDR(0x1f061000);
+
+       ath79_register_m25p80(NULL);
+
+       ath79_setup_ar933x_phy4_switch(false, false);
+
+       ath79_register_mdio(0, 0x0);
+
+       ath79_switch_data.phy4_mii_en = 1;
+       ath79_switch_data.phy_poll_mask = 0xfe;
+
+       /* LAN */
+       ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_MII;
+       ath79_eth0_data.phy_mask = BIT(4);
+       ath79_eth0_data.speed = SPEED_100;
+       ath79_init_mac(ath79_eth0_data.mac_addr, mac, 1);
+       ath79_register_eth(0);
+
+       /* WAN */
+       ath79_eth1_data.duplex = DUPLEX_FULL;
+       ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_GMII;
+       ath79_eth1_data.phy_mask = BIT(0);
+       ath79_eth1_data.speed = SPEED_1000;
+       ath79_init_mac(ath79_eth1_data.mac_addr, mac, 0);
+       ath79_register_eth(1);
+
+       ath79_register_pci();
+       ath79_register_usb();
+       ath79_register_wmac(art, NULL);
+}
+
+static void __init e600g_v2_setup(void)
+{
+       e600g_v2_common_setup();
+
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(e600g_v2_leds_gpio),
+                                e600g_v2_leds_gpio);
+
+       ath79_register_gpio_keys_polled(-1, E600G_V2_KEYS_POLL_INTERVAL,
+                                       ARRAY_SIZE(e600g_v2_gpio_keys),
+                                       e600g_v2_gpio_keys);
+}
+
+static void __init e600gac_v2_setup(void)
+{
+       e600g_v2_common_setup();
+
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(e600gac_v2_leds_gpio),
+                                e600gac_v2_leds_gpio);
+
+       ath79_register_gpio_keys_polled(-1, E600G_V2_KEYS_POLL_INTERVAL,
+                                       ARRAY_SIZE(e600gac_v2_gpio_keys),
+                                       e600gac_v2_gpio_keys);
+}
+
+MIPS_MACHINE(ATH79_MACH_E600G_V2, "E600G-V2", "WHQX E600G v2",
+            e600g_v2_setup);
+
+MIPS_MACHINE(ATH79_MACH_E600GAC_V2, "E600GAC-V2", "WHQX E600GAC v2",
+            e600gac_v2_setup);
index 497d794e01c9315c68ca3cb828d6c2b9cbb1ed28..e22ebd06f8961265c46a6b91872a46663811e672 100644 (file)
@@ -98,6 +98,9 @@ enum ath79_mach_type {
        ATH79_MACH_DR344,                       /* Wallys DR344 */
        ATH79_MACH_DR531,                       /* Wallys DR531 */
        ATH79_MACH_DRAGINO2,                    /* Dragino Version 2 */
+       ATH79_MACH_E1700AC_V2,                  /* WHQX E1700AC v2 */
+       ATH79_MACH_E600G_V2,                    /* WHQX E600G v2 */
+       ATH79_MACH_E600GAC_V2,                  /* WHQX E600GAC v2 */
        ATH79_MACH_EAP120,                      /* TP-LINK EAP120 */
        ATH79_MACH_EAP300V2,                    /* EnGenius EAP300 v2 */
        ATH79_MACH_EAP7660D,                    /* Senao EAP7660D */
index 9caf29aa5fa150de5a4d1285e11a85488f258cc4..2e5eb66e08f4775102b87727e279550e1d0cc370 100644 (file)
@@ -70,7 +70,9 @@ CONFIG_ATH79_MACH_DR342=y
 CONFIG_ATH79_MACH_DR344=y
 CONFIG_ATH79_MACH_DR531=y
 CONFIG_ATH79_MACH_DRAGINO2=y
+CONFIG_ATH79_MACH_E1700AC_V2=y
 CONFIG_ATH79_MACH_E2100L=y
+CONFIG_ATH79_MACH_E600G_V2=y
 CONFIG_ATH79_MACH_EAP120=y
 CONFIG_ATH79_MACH_EAP300V2=y
 CONFIG_ATH79_MACH_EAP7660D=y
index eeefde0a9807271d15fd368ff8d4f8dd42b35f7d..beb56bde7a0617db3af8e446f4d6b513170878c0 100644 (file)
@@ -281,6 +281,65 @@ define Device/dragino2
 endef
 TARGET_DEVICES += dragino2
 
+define Device/e1700ac-v2-16M
+  DEVICE_TITLE := WHQX E1700AC v2 (16MB flash)
+  DEVICE_PACKAGES := kmod-ath10k ath10k-firmware-qca988x kmod-usb-core \
+       kmod-usb2 kmod-usb-ledtrig-usbport
+  BOARDNAME := E1700AC-V2
+  SUPPORTED_DEVICES := e1700ac-v2
+  IMAGE_SIZE := 15936k
+  MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),64k(pri-data)ro,64k(art)ro,-(firmware)
+  IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) |\
+       append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += e1700ac-v2-16M
+
+define Device/e1700ac-v2-8M
+  $(Device/e1700ac-v2-16M)
+  DEVICE_TITLE := WHQX E1700AC v2 (8MB flash)
+  IMAGE_SIZE := 7744k
+endef
+TARGET_DEVICES += e1700ac-v2-8M
+
+define Device/e600g-v2-16M
+  DEVICE_TITLE := WHQX E600G v2 (16MB flash)
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 -swconfig
+  BOARDNAME := E600G-V2
+  SUPPORTED_DEVICES := e600g-v2
+  IMAGE_SIZE := 15936k
+  MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),64k(pri-data)ro,64k(art)ro,-(firmware)
+  IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) |\
+       append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += e600g-v2-16M
+
+define Device/e600g-v2-8M
+  $(Device/e600g-v2-16M)
+  DEVICE_TITLE := WHQX E600G v2 (8MB flash)
+  IMAGE_SIZE := 7744k
+endef
+TARGET_DEVICES += e600g-v2-8M
+
+define Device/e600gac-v2-16M
+  DEVICE_TITLE := WHQX E600GAC v2 (16MB flash)
+  DEVICE_PACKAGES := kmod-ath10k ath10k-firmware-qca9887 kmod-usb-core \
+       kmod-usb2 -swconfig
+  BOARDNAME := E600GAC-V2
+  SUPPORTED_DEVICES := e600gac-v2
+  IMAGE_SIZE := 15936k
+  MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),64k(pri-data)ro,64k(art)ro,-(firmware)
+  IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) |\
+       append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += e600gac-v2-16M
+
+define Device/e600gac-v2-8M
+  $(Device/e600gac-v2-16M)
+  DEVICE_TITLE := WHQX E600GAC v2 (8MB flash)
+  IMAGE_SIZE := 7744k
+endef
+TARGET_DEVICES += e600gac-v2-8M
+
 define Device/ew-balin
   DEVICE_TITLE := Embedded Wireless Balin Platform
   DEVICE_PACKAGES := kmod-usb-core kmod-usb-chipidea