ramips: Improve compatible for TP-Link Archer devices
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 3 Jul 2019 21:21:54 +0000 (23:21 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Wed, 10 Jul 2019 15:36:28 +0000 (17:36 +0200)
Include "Archer" in compatible as it is part of the device name.

Update Makefile device names where necessary to match compatible.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
13 files changed:
target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/ArcherC2-v1.dts
target/linux/ramips/dts/ArcherC20i.dts
target/linux/ramips/dts/ArcherC20v1.dts
target/linux/ramips/dts/ArcherC20v4.dts
target/linux/ramips/dts/ArcherC50.dts
target/linux/ramips/dts/ArcherC50V3.dts
target/linux/ramips/dts/ArcherC50V4.dts
target/linux/ramips/dts/ArcherMR200.dts
target/linux/ramips/image/mt7620.mk
target/linux/ramips/image/mt76x8.mk

index d020347d725a81d39f7e743667147b1a065f0235..62ea8b9ec6456fb2694aa67c1725249654eeb6bb 100755 (executable)
@@ -330,23 +330,23 @@ tplink,tl-wr841n-v14)
        ucidef_set_led_switch "lan" "lan" "$boardname:green:lan" "switch0" "0x1e"
        ucidef_set_led_switch "wan" "wan" "$boardname:green:wan" "switch0" "0x01"
        ;;
-tplink,c2-v1)
+tplink,archer-c2-v1)
        ucidef_set_led_switch "lan" "lan" "$boardname:green:lan" "switch1" "0x1e"
        ucidef_set_led_switch "wan" "wan" "$boardname:green:wan" "switch1" "0x01"
        set_wifi_led "$boardname:green:wlan"
        ;;
-tplink,c20-v1)
+tplink,archer-c20-v1)
        ucidef_set_led_switch "lan" "lan" "$boardname:blue:lan" "switch0" "0x1e"
        ucidef_set_led_switch "wan" "wan" "$boardname:blue:wan" "switch0" "0x01"
        ucidef_set_led_netdev "wlan2g" "wlan2g" "$boardname:blue:wlan2g" "wlan0"
        ;;
-tplink,c20-v4)
+tplink,archer-c20-v4)
        ucidef_set_led_switch "lan" "lan" "$boardname:green:lan" "switch0" "0x1e"
        ucidef_set_led_switch "wan" "wan" "$boardname:green:wan" "switch0" "0x01"
        ucidef_set_led_netdev "wlan2g" "wlan2g" "$boardname:green:wlan2g" "wlan0"
        ;;
-tplink,c50-v3|\
-tplink,c50-v4)
+tplink,archer-c50-v3|\
+tplink,archer-c50-v4)
        ucidef_set_led_switch "lan" "lan" "$boardname:green:lan" "switch0" "0x1e"
        ucidef_set_led_switch "wan" "wan" "$boardname:green:wan" "switch0" "0x01"
        ucidef_set_led_wlan "wlan2g" "wlan2g" "$boardname:green:wlan2g" "phy0tpt"
index b13590566ce19fe51cf68b6fb683011bc03d9b7d..ec2be9715cafc7fcea039a3a385603ed144dbf4a 100755 (executable)
@@ -238,9 +238,9 @@ ramips_setup_interfaces()
        mzk-wdpr|\
        rt-n14u|\
        skylab,skw92a|\
-       tplink,c20-v4|\
-       tplink,c50-v3|\
-       tplink,c50-v4|\
+       tplink,archer-c20-v4|\
+       tplink,archer-c50-v3|\
+       tplink,archer-c50-v4|\
        tplink,tl-mr3420-v5|\
        tplink,tl-wr842n-v5|\
        tl-wr840n-v4|\
@@ -261,7 +261,7 @@ ramips_setup_interfaces()
                        "1:lan" "2:lan" "3:lan" "4:lan" "0:wan" "6@eth0"
                ;;
        c50|\
-       tplink,c20-v1)
+       tplink,archer-c20-v1)
                ucidef_add_switch "switch0" \
                        "1:lan:3" "2:lan:4" "3:lan:1" "4:lan:2" "0:wan" "6@eth0"
                ;;
@@ -324,7 +324,7 @@ ramips_setup_interfaces()
                        "0:lan" "1:lan" "2:lan" "3:lan" "4:wan" "6@eth0"
                ;;
        edimax,br-6478ac-v2|\
-       tplink,c2-v1)
+       tplink,archer-c2-v1)
                ucidef_add_switch "switch1" \
                        "1:lan" "2:lan" "3:lan" "4:lan" "0:wan" "6@eth0"
                ;;
index 7372a379399316227d8cea7c8d0eafd0c6315498..65522b23fd6529ec0a8e4b651d60265e6c6ddb5b 100755 (executable)
@@ -45,7 +45,7 @@ platform_do_upgrade() {
        xiaomi,mir3p)
                nand_do_upgrade "$ARGV"
                ;;
-       tplink,c50-v4)
+       tplink,archer-c50-v4)
                MTD_ARGS="-t romfile"
                default_do_upgrade "$ARGV"
                ;;
index 921a50a56cd15ecc4a6c63c168c250c6f8fe29a1..e20b8735693294802d0d70bf3af6910c26e103fa 100644 (file)
@@ -6,7 +6,7 @@
 #include <dt-bindings/input/input.h>
 
 / {
-       compatible = "tplink,c2-v1", "ralink,mt7620a-soc";
+       compatible = "tplink,archer-c2-v1", "ralink,mt7620a-soc";
        model = "TP-Link Archer C2 v1";
 
        aliases {
index cf715a413f97c9ad46f1772b99463083a179f4fa..7dfaddeee461c9c03197fb762160df88ca49b7ee 100644 (file)
@@ -6,7 +6,7 @@
 #include <dt-bindings/input/input.h>
 
 / {
-       compatible = "tplink,c20i", "ralink,mt7620a-soc";
+       compatible = "tplink,archer-c20i", "ralink,mt7620a-soc";
        model = "TP-Link Archer C20i";
 
        chosen {
index 39e33b8ff0856116acaadce18684550a6a91e203..602cc70e027b194cd47fb069c3600007dd33019c 100644 (file)
@@ -6,7 +6,7 @@
 #include <dt-bindings/gpio/gpio.h>
 
 / {
-       compatible = "tplink,c20-v1", "ralink,mt7620a-soc";
+       compatible = "tplink,archer-c20-v1", "ralink,mt7620a-soc";
        model = "TP-Link Archer C20 v1";
 
        aliases {
index aaafcc52f538426998331ce96976b3ef26443944..f207ac0d4695fb8efed826c01fee043d3b2cd251 100644 (file)
@@ -6,7 +6,7 @@
 #include <dt-bindings/gpio/gpio.h>
 
 / {
-       compatible = "tplink,c20-v4", "mediatek,mt7628an-soc";
+       compatible = "tplink,archer-c20-v4", "mediatek,mt7628an-soc";
        model = "TP-Link Archer C20 v4";
 
        aliases {
index b6f5bed0b71e2e2a16c6dcdbab7d1e9f44be2390..b1e13bebea5d08bc9e58366d6325d5b7127d9915 100644 (file)
@@ -6,8 +6,8 @@
 #include <dt-bindings/gpio/gpio.h>
 
 / {
-       compatible = "tplink,c50", "ralink,mt7620a-soc";
-       model = "TP-Link Archer C50";
+       compatible = "tplink,archer-c50-v1", "ralink,mt7620a-soc";
+       model = "TP-Link Archer C50 v1";
 
        aliases {
                led-boot = &led_power;
index cc4e72819f9a2bf5055174b7f8bcd7091f82281b..32cc42ef5879c7751baa3114a6849ccf8518f8ff 100644 (file)
@@ -6,7 +6,7 @@
 #include <dt-bindings/input/input.h>
 
 / {
-       compatible = "tplink,c50-v3", "mediatek,mt7628an-soc";
+       compatible = "tplink,archer-c50-v3", "mediatek,mt7628an-soc";
        model = "TP-Link Archer C50 v3";
 
        aliases {
index 37f388620e3bf2cb9fb3f79e036dde0f987a8a5f..7d129a5f804768728d43980c27b07987cf7f827d 100644 (file)
@@ -7,7 +7,7 @@
 #include <dt-bindings/input/input.h>
 
 / {
-       compatible = "tplink,c50-v4", "mediatek,mt7628an-soc";
+       compatible = "tplink,archer-c50-v4", "mediatek,mt7628an-soc";
        model = "TP-Link Archer C50 v4";
 
        aliases {
index ff00dbe958416adb7e0b0faed00226754f79fd33..566b2431fc5ba8d7d1ea9fd723d60685d3dd3406 100644 (file)
@@ -6,7 +6,7 @@
 #include <dt-bindings/input/input.h>
 
 / {
-       compatible = "tplink,mr200", "ralink,mt7620a-soc";
+       compatible = "tplink,archer-mr200", "ralink,mt7620a-soc";
        model = "TP-Link Archer MR200";
 
        aliases {
index a8a539121693eb6d054fda9f731552646ec4b734..abf2b1eed64a7e618d046b806e7b92602c9af803 100644 (file)
@@ -729,9 +729,10 @@ define Device/edimax_ew-7478apc
 endef
 TARGET_DEVICES += edimax_ew-7478apc
 
-define Device/tplink_c2-v1
+define Device/tplink_archer-c2-v1
   $(Device/Archer)
   DTS := ArcherC2-v1
+  SUPPORTED_DEVICES += tplink,c2-v1
   TPLINK_FLASHLAYOUT := 8Mmtk
   TPLINK_HWID := 0xc7500001
   TPLINK_HWREV := 50
@@ -740,11 +741,12 @@ define Device/tplink_c2-v1
   DEVICE_VARIANT := v1
   DEVICE_PACKAGES := kmod-mt76x0e kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport kmod-switch-rtl8366-smi kmod-switch-rtl8367b
 endef
-TARGET_DEVICES += tplink_c2-v1
+TARGET_DEVICES += tplink_archer-c2-v1
 
-define Device/tplink_c20-v1
+define Device/tplink_archer-c20-v1
   $(Device/Archer)
   DTS := ArcherC20v1
+  SUPPORTED_DEVICES += tplink,c20-v1
   TPLINK_FLASHLAYOUT := 8Mmtk
   TPLINK_HWID := 0xc2000001
   TPLINK_HWREV := 0x44
@@ -754,7 +756,7 @@ define Device/tplink_c20-v1
   DEVICE_VARIANT := v1
   DEVICE_PACKAGES := kmod-mt76x0e kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport
 endef
-TARGET_DEVICES += tplink_c20-v1
+TARGET_DEVICES += tplink_archer-c20-v1
 
 define Device/vonets_var11n-300
   DTS := VAR11N-300
index 9ad77e83db4471e2ecb20422bfb5fe4201995454..96b067e90059fc41c673993082e82a977a631d09 100644 (file)
@@ -302,7 +302,7 @@ define Device/tplink_tl-wr841n-v14
 endef
 TARGET_DEVICES += tplink_tl-wr841n-v14
 
-define Device/tplink_c20-v4
+define Device/tplink_archer-c20-v4
   $(Device/tplink)
   DTS := ArcherC20v4
   IMAGE_SIZE := 7808k
@@ -314,10 +314,11 @@ define Device/tplink_c20-v4
   TPLINK_HWREVADD := 0x4
   TPLINK_HVERSION := 3
   DEVICE_PACKAGES := kmod-mt76x0e
+  SUPPORTED_DEVICES += tplink,c20-v4
 endef
-TARGET_DEVICES += tplink_c20-v4
+TARGET_DEVICES += tplink_archer-c20-v4
 
-define Device/tplink_c50-v3
+define Device/tplink_archer-c50-v3
   $(Device/tplink)
   DTS := ArcherC50V3
   IMAGE_SIZE := 7808k
@@ -329,10 +330,11 @@ define Device/tplink_c50-v3
   TPLINK_HWREVADD := 0x1
   TPLINK_HVERSION := 3
   DEVICE_PACKAGES := kmod-mt76x2
+  SUPPORTED_DEVICES += tplink,c50-v3
 endef
-TARGET_DEVICES += tplink_c50-v3
+TARGET_DEVICES += tplink_archer-c50-v3
 
-define Device/tplink_c50-v4
+define Device/tplink_archer-c50-v4
   $(Device/tplink)
   DTS := ArcherC50V4
   IMAGE_SIZE := 7616k
@@ -345,8 +347,9 @@ define Device/tplink_c50-v4
   TPLINK_HVERSION := 3
   DEVICE_PACKAGES := kmod-mt76x2
   IMAGES := sysupgrade.bin
+  SUPPORTED_DEVICES += tplink,c50-v4
 endef
-TARGET_DEVICES += tplink_c50-v4
+TARGET_DEVICES += tplink_archer-c50-v4
 
 define Device/tplink_tl-mr3020-v3
   $(Device/tplink)