libsepol: break out chkcon utility
authorDaniel Golle <daniel@makrotopia.org>
Sun, 27 Sep 2020 16:21:23 +0000 (17:21 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Sun, 27 Sep 2020 16:22:01 +0000 (17:22 +0100)
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/libs/libsepol/Makefile

index 2a6bd46ad0a10b2cc9f7995c67216eb2ef64ef78..8ceb7164a71d4fa46f9c20901727e7f9ee23c293 100644 (file)
@@ -30,6 +30,18 @@ define Package/libsepol/description
        depend upon or use any of the other SELinux components.
 endef
 
+define Package/chkcon
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=+libsepol
+  TITLE:=libsepol chkcon security context validation tool
+  URL:=http://selinuxproject.org/page/Main_Page
+endef
+
+define Package/chkcon/description
+       chkcon - determine if a security context is valid for a given binary policy
+endef
+
 HOST_MAKE_FLAGS += \
        PREFIX=$(STAGING_DIR_HOSTPKG) \
        SHLIBDIR=$(STAGING_DIR_HOSTPKG)/lib
@@ -62,5 +74,11 @@ define Package/libsepol/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsepol.so.* $(1)/usr/lib/
 endef
 
+define Package/chkcon/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/chkcon $(1)/usr/bin/
+endef
+
 $(eval $(call HostBuild))
 $(eval $(call BuildPackage,libsepol))
+$(eval $(call BuildPackage,chkcon))