kernel: bump 4.14 to 4.14.112
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 18 Apr 2019 13:04:42 +0000 (15:04 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 22 Apr 2019 19:15:17 +0000 (21:15 +0200)
Refreshed all patches.

New symbol:
- CONFIG_LDISC_AUTOLOAD

Compile-tested on: ar71xx, cns3xxx, imx6, x86_64
Runtime-tested on: ar71xx, cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/ar71xx/patches-4.14/509-MIPS-ath79-process-board-kernel-option.patch
target/linux/ar71xx/patches-4.14/604-MIPS-ath79-no-of.patch
target/linux/ath79/patches-4.14/0027-MIPS-ath79-drop-legacy-IRQ-code.patch
target/linux/ath79/patches-4.14/0028-MIPS-ath79-drop-machfiles.patch
target/linux/generic/config-4.14
target/linux/generic/pending-4.14/103-MIPS-perf-ath79-Fix-perfcount-IRQ-assignment.patch
target/linux/layerscape/patches-4.14/816-pcie-support-layerscape.patch
target/linux/mvebu/patches-4.14/408-sfp-move-module-eeprom-ethtool-access-into-netdev-co.patch

index 72bd2ede1b97536ddaa3f7cc0b0f3b7994b7c253..a6c0f6e59cb9daa6b37b1f3941982b1da6e1c2ae 100644 (file)
@@ -4,12 +4,12 @@ LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .136
 LINUX_VERSION-4.9 = .169
-LINUX_VERSION-4.14 = .111
+LINUX_VERSION-4.14 = .112
 LINUX_VERSION-4.19 = .34
 
 LINUX_KERNEL_HASH-3.18.136 = 48c8775013d23229462134f911bbb14c7935096fcccfb19ce28ecd5f7154f35c
 LINUX_KERNEL_HASH-4.9.169 = b776636c63a555961cfe9f6f4a315e65ab0ff3376acdb3cf5ad654808ff8d6b0
-LINUX_KERNEL_HASH-4.14.111 = f8197d56553f864d1d2e97abbe4fca50f8ab5e72089c292d22f0e4395340a6e8
+LINUX_KERNEL_HASH-4.14.112 = 326101e2cc80a0d7e643074fe9e63f0d6a9c8cf97033f8a07848de373203e472
 LINUX_KERNEL_HASH-4.19.34 = dd795e2a1fddbee5b03c3bb55a1926829cc08df4fdcabce62dda717ba087b8cc
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 3091ab69b60e56079a22ed2c3c3015ed000c5cf4..139b09c1b0e7b71d07cfbaa64d0e21c05cace700 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/setup.c
 +++ b/arch/mips/ath79/setup.c
-@@ -283,6 +283,8 @@ void __init plat_time_init(void)
+@@ -277,6 +277,8 @@ void __init plat_time_init(void)
        mips_hpt_frequency = cpu_clk_rate / 2;
  }
  
index 5be33f9b08de129eab3b8d99f360a6baf615f3bc..2e7d5d823275d57993201bf82f6e8ad8b1de272b 100644 (file)
@@ -10,7 +10,7 @@
  
 --- a/arch/mips/ath79/setup.c
 +++ b/arch/mips/ath79/setup.c
-@@ -196,16 +196,20 @@ unsigned int get_c0_compare_int(void)
+@@ -190,16 +190,20 @@ unsigned int get_c0_compare_int(void)
  
  void __init plat_mem_setup(void)
  {
@@ -31,7 +31,7 @@
  
        if (mips_machtype != ATH79_MACH_GENERIC_OF) {
                ath79_reset_base = ioremap_nocache(AR71XX_RESET_BASE,
-@@ -301,17 +305,21 @@ static int __init ath79_setup(void)
+@@ -295,17 +299,21 @@ static int __init ath79_setup(void)
  
  arch_initcall(ath79_setup);
  
index 79f003d2ea3df63157deda642af56d3bbabd15c5..6586f084314145968c31768451ef2337a6a8d4d6 100644 (file)
@@ -208,7 +208,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
  
  #include <asm/bootinfo.h>
  #include <asm/idle.h>
-@@ -311,6 +312,11 @@ void __init plat_time_init(void)
+@@ -305,6 +306,11 @@ void __init plat_time_init(void)
        mips_hpt_frequency = cpu_clk_rate / 2;
  }
  
index 2d87f700744c5976320ef21f8a5bad290af6a91a..bb5acde8bb9f22a7c913e40a03846ddb0cb75b6f 100644 (file)
@@ -938,7 +938,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
  
  #define ATH79_SYS_TYPE_LEN    64
  
-@@ -236,25 +235,21 @@ void __init plat_mem_setup(void)
+@@ -230,25 +229,21 @@ void __init plat_mem_setup(void)
        else if (fw_passed_dtb)
                __dt_setup_arch((void *)KSEG0ADDR(fw_passed_dtb));
  
@@ -973,7 +973,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
  {
        struct device_node *np;
        struct clk *clk;
-@@ -284,66 +279,12 @@ static void __init ath79_of_plat_time_in
+@@ -278,66 +273,12 @@ static void __init ath79_of_plat_time_in
        clk_put(clk);
  }
  
index 5cc3c49aeb061e7c722ad68585e5cd4fa1cc48ca..6f2db609893c48dcc8f5395254dd0a4366f1798d 100644 (file)
@@ -2327,6 +2327,7 @@ CONFIG_LBDAF=y
 # CONFIG_LCD_S6E63M0 is not set
 # CONFIG_LCD_TDO24M is not set
 # CONFIG_LCD_VGG2432A4 is not set
+CONFIG_LDISC_AUTOLOAD=y
 # CONFIG_LDM_PARTITION is not set
 CONFIG_LD_DEAD_CODE_DATA_ELIMINATION=y
 # CONFIG_LEDS_BCM6328 is not set
index 9e97f8af2dbd90baf3236c2fd262eb4c82c94334..1990e87055b2fa84860284b5ffe2dcd909316c57 100644 (file)
@@ -66,11 +66,9 @@ Changes since v1:
  drivers/irqchip/irq-ath79-misc.c | 11 +++++++++++
  2 files changed, 11 insertions(+), 6 deletions(-)
 
-diff --git a/arch/mips/ath79/setup.c b/arch/mips/ath79/setup.c
-index 4a70c5d..25a5789 100644
 --- a/arch/mips/ath79/setup.c
 +++ b/arch/mips/ath79/setup.c
-@@ -210,12 +210,6 @@ const char *get_system_type(void)
+@@ -183,12 +183,6 @@ const char *get_system_type(void)
        return ath79_sys_type;
  }
  
@@ -83,8 +81,6 @@ index 4a70c5d..25a5789 100644
  unsigned int get_c0_compare_int(void)
  {
        return CP0_LEGACY_COMPARE_IRQ;
-diff --git a/drivers/irqchip/irq-ath79-misc.c b/drivers/irqchip/irq-ath79-misc.c
-index aa72907..0390603 100644
 --- a/drivers/irqchip/irq-ath79-misc.c
 +++ b/drivers/irqchip/irq-ath79-misc.c
 @@ -22,6 +22,15 @@
@@ -103,7 +99,7 @@ index aa72907..0390603 100644
  
  static void ath79_misc_irq_handler(struct irq_desc *desc)
  {
-@@ -113,6 +122,8 @@ static void __init ath79_misc_intc_domain_init(
+@@ -113,6 +122,8 @@ static void __init ath79_misc_intc_domai
  {
        void __iomem *base = domain->host_data;
  
@@ -112,6 +108,3 @@ index aa72907..0390603 100644
        /* Disable and clear all interrupts */
        __raw_writel(0, base + AR71XX_RESET_REG_MISC_INT_ENABLE);
        __raw_writel(0, base + AR71XX_RESET_REG_MISC_INT_STATUS);
--- 
-1.9.1
-
index 68d6a31a5ebb285ba049f6edd038e6a08261ecc3..5f055891d6f79e3121fa9f3908ad984b89315084 100644 (file)
@@ -572,7 +572,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
  static void quirk_no_pm_reset(struct pci_dev *dev)
  {
        /*
-@@ -4857,3 +4864,11 @@ static void quirk_no_ats(struct pci_dev
+@@ -4859,3 +4866,11 @@ static void quirk_no_ats(struct pci_dev
  /* AMD Stoney platform GPU */
  DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_ATI, 0x98e4, quirk_no_ats);
  #endif /* CONFIG_PCI_ATS */
index 540ef51ba476028925d8bdbdab38b8d04f742df3..1de8caab8bdae7c3f9b6aea35460f6c7b3e45760 100644 (file)
@@ -159,7 +159,7 @@ Signed-off-by: Russell King <rmk+kernel@armlinux.org.uk>
  #include <linux/slab.h>
  #include <linux/rtnetlink.h>
  #include <linux/sched/signal.h>
-@@ -2190,6 +2191,9 @@ static int __ethtool_get_module_info(str
+@@ -2201,6 +2202,9 @@ static int __ethtool_get_module_info(str
        const struct ethtool_ops *ops = dev->ethtool_ops;
        struct phy_device *phydev = dev->phydev;
  
@@ -169,7 +169,7 @@ Signed-off-by: Russell King <rmk+kernel@armlinux.org.uk>
        if (phydev && phydev->drv && phydev->drv->module_info)
                return phydev->drv->module_info(phydev, modinfo);
  
-@@ -2224,6 +2228,9 @@ static int __ethtool_get_module_eeprom(s
+@@ -2235,6 +2239,9 @@ static int __ethtool_get_module_eeprom(s
        const struct ethtool_ops *ops = dev->ethtool_ops;
        struct phy_device *phydev = dev->phydev;