toolchain: Use binutils 2.32 by default for ARC
authorDaniel Engberg <daniel.engberg.lists@pyret.net>
Wed, 27 Feb 2019 10:00:08 +0000 (10:00 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 20 Mar 2019 17:23:39 +0000 (18:23 +0100)
Use binutils 2.32 by default for ARC targets

Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
toolchain/binutils/Config.in
toolchain/binutils/Config.version

index 950ce83..231c197 100644 (file)
@@ -3,7 +3,7 @@
 choice
        prompt "Binutils Version" if TOOLCHAINOPTS
        default BINUTILS_USE_VERSION_2_31_1 if !arc
-       default BINUTILS_USE_VERSION_2_29_ARC if arc
+       default BINUTILS_USE_VERSION_2_32 if arc
        help
          Select the version of binutils you wish to use.
 
@@ -23,7 +23,6 @@ choice
                select BINUTILS_VERSION_2_31_1
 
        config BINUTILS_USE_VERSION_2_32
-               depends on !arc
                bool "Binutils 2.32"
                select BINUTILS_VERSION_2_32
 
index f125bf7..3a0fc5b 100644 (file)
@@ -1,5 +1,4 @@
 config BINUTILS_VERSION_2_29_ARC
-       default y if (!TOOLCHAINOPTS && arc)
        bool
 
 config BINUTILS_VERSION_2_29_1
@@ -10,6 +9,7 @@ config BINUTILS_VERSION_2_31_1
        bool
 
 config BINUTILS_VERSION_2_32
+       default y if (!TOOLCHAINOPTS && arc)
        bool
 
 config BINUTILS_VERSION