base-files: do not assume that "top" is busybox' top, but try to call the applet...
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 8 Nov 2011 18:48:38 +0000 (18:48 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 8 Nov 2011 18:48:38 +0000 (18:48 +0000)
SVN-Revision: 28862

package/base-files/Makefile
package/base-files/files/lib/upgrade/common.sh

index 2b1cfa13b3e9349f9aa9f298049be232a12a114a..e29e63b3d930fabab5ce629acefc96d73bd1f24f 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=89
+PKG_RELEASE:=90
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index e0db37e7502db911b87b2f97703fc914c41c1a85..a5a6fbf7e56eaffc92d926191c9b4ea0e8a8d041 100644 (file)
@@ -80,7 +80,7 @@ run_ramfs() { # <command> [...]
 kill_remaining() { # [ <signal> ]
        local sig="${1:-TERM}"
        echo -n "Sending $sig to remaining processes ... "
-       top -bn1 | while read pid ppid user stat vsz pvsz pcpu cmd args; do
+       /bin/busybox top -bn1 2>/dev/null | while read pid ppid user stat vsz pvsz pcpu cmd args; do
                case "$pid" in
                        [0-9]*) : ;;
                        *) continue ;;