ath79: Ubiquiti Airmax M: add relocate-kernel to invalidate cache
authorMatthias Schiffer <mschiffer@universe-factory.net>
Thu, 26 Apr 2018 18:04:48 +0000 (20:04 +0200)
committerMatthias Schiffer <mschiffer@universe-factory.net>
Tue, 8 May 2018 19:14:24 +0000 (21:14 +0200)
Apply ar71xx fix for broken Ubiquiti bootloader to ath79 as well.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
target/linux/ath79/image/Makefile
target/linux/ath79/image/generic-ubnt.mk

index 5f1edcbdb262a2c5b865edbc5fbc88bab6b1d5da..cc71c319978080eeb1a963fce244252bc10a1824 100644 (file)
@@ -36,6 +36,19 @@ define Build/loader-okli
        mv "$@.new" "$@"
 endef
 
+define Build/relocate-kernel
+       rm -rf $@.relocate
+       $(CP) ../../generic/image/relocate $@.relocate
+       $(MAKE) -j1 -C $@.relocate KERNEL_ADDR=$(KERNEL_LOADADDR) CROSS_COMPILE=$(TARGET_CROSS)
+       ( \
+               dd if=$@.relocate/loader.bin bs=32 conv=sync && \
+               perl -e '@s = stat("$@"); print pack("N", @s[7])' && \
+               cat "$@" \
+       ) > "$@.new"
+       mv "$@.new" "$@"
+       rm -rf $@.relocate
+endef
+
 define Build/copy-file
        cat "$(1)" > "$@"
 endef
index c0370ad58979459ce6b2dc329be066c106b86529..17c89fcb1c76d1bff3f6c4bfe037ed898102a9e1 100644 (file)
@@ -52,6 +52,7 @@ define Device/ubnt-xm
   UBNT_TYPE := XM
   UBNT_CHIP := ar7240
   ATH_SOC := ar7241
+  KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma | uImage lzma
 endef
 
 define Device/ubnt-xw