comgt-3g: enable modem before to setpin
authorGiuseppe Lippolis <giu.lippolis@gmail.com>
Tue, 9 May 2017 18:23:35 +0000 (20:23 +0200)
committerJohn Crispin <john@phrozen.org>
Thu, 18 May 2017 05:07:00 +0000 (07:07 +0200)
some modems needs to be enabled with CFUN=1 before to set the pin

Signed-off-by: Giuseppe Lippolis <giu.lippolis@gmail.com>
package/network/utils/comgt/Makefile
package/network/utils/comgt/files/setpin.gcom

index 3926016581938101c13d5d66d2eddc4a48cbdb39..ce99a2a6888629e2b7332d70ddf1dcadf6353b10 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=comgt
 PKG_VERSION:=0.32
 
 PKG_NAME:=comgt
 PKG_VERSION:=0.32
-PKG_RELEASE:=28
+PKG_RELEASE:=29
 
 PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/comgt
 
 PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/comgt
index 66350fe20b7fe9776fed4c83424cc01787b03a9e..a3f3402797e09f22b8c3882cd960d9924f0157c9 100644 (file)
@@ -7,6 +7,7 @@ opengt
 
  let c=0
 :start
 
  let c=0
 :start
+ send "AT+CFUN=1^m"
  send "AT+CPIN?^m"
  waitfor 15 "SIM PUK","SIM PIN","READY","ERROR","ERR"
  if % = -1 goto timeout
  send "AT+CPIN?^m"
  waitfor 15 "SIM PUK","SIM PIN","READY","ERROR","ERR"
  if % = -1 goto timeout