mklibs: upgrade to 0.1.35
authorLuka Perkov <luka@openwrt.org>
Tue, 26 Feb 2013 21:49:11 +0000 (21:49 +0000)
committerLuka Perkov <luka@openwrt.org>
Tue, 26 Feb 2013 21:49:11 +0000 (21:49 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 35818

tools/Makefile
tools/mklibs/Makefile
tools/mklibs/patches/001-compile.patch [new file with mode: 0644]

index 802d6c9aee2f2f1f91a42be6fc8a918d0fae33b6..d922c5364cece37adb396c928f6453b3dd794846 100644 (file)
@@ -58,6 +58,7 @@ $(curdir)/ppl/compile := $(curdir)/gmp/install
 $(curdir)/cloog/compile := $(curdir)/ppl/install
 $(curdir)/mtd-utils/compile := $(curdir)/e2fsprogs/install $(curdir)/xz/install
 $(curdir)/mkimage/compile := $(curdir)/sed/install
+$(curdir)/mklibs/compile := $(curdir)/automake/install
 $(curdir)/qemu/compile := $(curdir)/e2fsprogs/install
 $(curdir)/upslug2/compile := $(curdir)/automake/install
 $(curdir)/mm-macros/compile := $(curdir)/automake/install
index fd3d233c4700600526c7d195ebcbec3e51e2be53..fa0bce70d9bd509aa31a0a17a556e161b2bd9536 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2012 OpenWrt.org
+# Copyright (C) 2009-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,11 +7,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mklibs
-PKG_VERSION:=0.1.34
+PKG_VERSION:=0.1.35
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/m/mklibs/
-PKG_MD5SUM:=afe0ed527ba96b8a882b5de350603007
+PKG_MD5SUM:=3d2a4bd0bbf5ba964b0a1ecdafd1ea9a
+
+HOST_FIXUP:=autoreconf
 
 include $(INCLUDE_DIR)/host-build.mk
 
diff --git a/tools/mklibs/patches/001-compile.patch b/tools/mklibs/patches/001-compile.patch
new file mode 100644 (file)
index 0000000..09b831a
--- /dev/null
@@ -0,0 +1,8 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1,4 +1,4 @@
+-AC_INIT([mklibs],m4_esyscmd(dpkg-parsechangelog | perl -ne 'print $1 if m/^Version: (.*)$/;'))
++AC_INIT([mklibs],m4_esyscmd([head -n1 debian/changelog | awk -F'[\\\\(\\\\)]' '{ print $2 }' | xargs -I{} echo -n {}]))
+ AM_INIT_AUTOMAKE([foreign no-define])
+ AC_CONFIG_HEADERS([config.h])
+ AM_MAINTAINER_MODE