make UbinizeImage work nicely without a kernel volume
authorImre Kaloz <kaloz@openwrt.org>
Fri, 27 Jun 2014 12:58:08 +0000 (12:58 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Fri, 27 Jun 2014 12:58:08 +0000 (12:58 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
SVN-Revision: 41359

include/image.mk
scripts/ubinize-image.sh

index 71971e21ca50910e5688114713a0fc5fe3efe508..5e4dfb28e965925659b4f4f199388f5377b4a028 100644 (file)
@@ -142,15 +142,14 @@ ifneq ($(CONFIG_NAND_SUPPORT),)
                "$(BIN_DIR)/$(IMG_PREFIX)-$(1)-$(2)-sysupgrade.tar" sysupgrade-$(1))
    endef
 # $(1) board name
                "$(BIN_DIR)/$(IMG_PREFIX)-$(1)-$(2)-sysupgrade.tar" sysupgrade-$(1))
    endef
 # $(1) board name
-# $(2) ubinize-image options (e.g. --no-kernel and/or --uboot-env)
+# $(2) ubinize-image options (e.g. --uboot-env and/or --kernel kernelimage)
 # $(3) rootfstype (e.g. squashfs or ubifs)
 # $(3) rootfstype (e.g. squashfs or ubifs)
-# $(4) kernel image file
-# $(5) options to pass-through to ubinize (i.e. $($(PROFILE)_UBI_OPTS)))
+# $(4) options to pass-through to ubinize (i.e. $($(PROFILE)_UBI_OPTS)))
    define Image/Build/UbinizeImage
        sh $(TOPDIR)/scripts/ubinize-image.sh $(2) \
    define Image/Build/UbinizeImage
        sh $(TOPDIR)/scripts/ubinize-image.sh $(2) \
-               "$(KDIR)/root.$(3)" "$(4)" \
+               "$(KDIR)/root.$(3)" \
                "$(BIN_DIR)/$(IMG_PREFIX)-$(1)-$(3)-ubinized.bin" \
                "$(BIN_DIR)/$(IMG_PREFIX)-$(1)-$(3)-ubinized.bin" \
-               $(5)
+               $(4)
    endef
 
 endif
    endef
 
 endif
index 6ffedc5f32620deec6c9de494001fa59a32638be..1b782a6cdc736b7fb2a0b76aea020b527051d1cf 100755 (executable)
@@ -1,7 +1,6 @@
 #!/bin/sh
 
 ubootenv=""
 #!/bin/sh
 
 ubootenv=""
-nokernel=""
 ubinize_param=""
 kernel=""
 rootfs=""
 ubinize_param=""
 kernel=""
 rootfs=""
@@ -63,8 +62,8 @@ while [ "$1" ]; do
                shift
                continue
                ;;
                shift
                continue
                ;;
-       "--no-kernel")
-               nokernel="nokernel"
+       "--kernel")
+               kernel="$2"
                shift
                continue
                ;;
                shift
                continue
                ;;
@@ -73,11 +72,6 @@ while [ "$1" ]; do
                break
                ;;
        *)
                break
                ;;
        *)
-               if [ ! "$kernel" -a ! "$nokernel" ]; then
-                       kernel=$1
-                       shift
-                       continue
-               fi
                if [ ! "$rootfs" ]; then
                        rootfs=$1
                        shift
                if [ ! "$rootfs" ]; then
                        rootfs=$1
                        shift
@@ -92,8 +86,8 @@ while [ "$1" ]; do
        esac
 done
 
        esac
 done
 
-if [ ! -r "$rootfs" -o ! -r "$kernel" -a ! "$nokernel" -o ! "$outfile" ]; then
-       echo "syntax: $0 [--no-kernel] [--uboot-env] rootfs [kernel] out [ubinize opts]"
+if [ ! -r "$rootfs" -o ! -r "$kernel" -a ! "$outfile" ]; then
+       echo "syntax: $0 [--uboot-env] [--kernel kernelimage] rootfs out [ubinize opts]"
        exit 1
 fi
 
        exit 1
 fi