linux: fix kmod-usb-net-* for >= 3.17
authorJohn Crispin <john@openwrt.org>
Mon, 16 Feb 2015 08:00:17 +0000 (08:00 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 16 Feb 2015 08:00:17 +0000 (08:00 +0000)
Kernel commit 1bb5a356c3ea ("net: reduce USB network driver config
options.") hid the USB network drivers behind the new config symbol
CONFIG_USB_NET_DRIVERS.

Signed-off-by: Bjørn Mork <bjorn@mork.no>
SVN-Revision: 44460

package/kernel/linux/modules/usb.mk

index 431c7baa2c3b24b8228750c0127a2a4fa5132b80..6faa437bcae55c2ffed8e5f6565af7a205ed5e00 100644 (file)
@@ -992,7 +992,8 @@ $(eval $(call KernelPackage,usb-atm-cxacru))
 define KernelPackage/usb-net
   TITLE:=Kernel modules for USB-to-Ethernet convertors
   DEPENDS:=+kmod-mii
-  KCONFIG:=CONFIG_USB_USBNET
+  KCONFIG:=CONFIG_USB_USBNET \
+       CONFIG_USB_NET_DRIVERS@ge3.18
   AUTOLOAD:=$(call AutoProbe,usbnet)
   FILES:=$(LINUX_DIR)/drivers/$(USBNET_DIR)/usbnet.ko
   $(call AddDepends/usb)