rebuild ipkg control files if Makefile changes
authorMike Baker <mbm@openwrt.org>
Mon, 10 Jul 2006 23:21:08 +0000 (23:21 +0000)
committerMike Baker <mbm@openwrt.org>
Mon, 10 Jul 2006 23:21:08 +0000 (23:21 +0000)
SVN-Revision: 4124

openwrt/include/package.mk

index 618c3c5553b2e9615a72cafd81981c71ed3fef7b..7aea314abc1e5641881bfd7f8117543c9143a406 100644 (file)
@@ -173,7 +173,7 @@ define BuildPackage
   $(eval $(call BuildIPKGVariable,$(1),postinst))
   $(eval $(call BuildIPKGVariable,$(1),prerm))
   $(eval $(call BuildIPKGVariable,$(1),postrm))
-  $$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.prepared
+  $$(IDIR_$(1))/CONTROL/control: Makefile $(PKG_BUILD_DIR)/.prepared
        mkdir -p $$(IDIR_$(1))/CONTROL
        echo "Package: $(1)" > $$(IDIR_$(1))/CONTROL/control
        echo "Version: $(VERSION)" >> $$(IDIR_$(1))/CONTROL/control