kernel: add kmod-iio-ccs811
authorStijn Tintel <stijn@linux-ipv6.be>
Tue, 5 Feb 2019 00:25:22 +0000 (02:25 +0200)
committerStijn Tintel <stijn@linux-ipv6.be>
Sat, 23 Feb 2019 15:22:53 +0000 (17:22 +0200)
This module supports the AMS CCS811 VOC sensor.
Tested on Raspberry Pi Zero W and ODROID C2.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
package/kernel/linux/modules/iio.mk

index fe682b310099934bb931a6a563a6758e82fb9f67..44a4806b34f7652d3bffa081435e8bb7ce5c7b6d 100644 (file)
@@ -200,6 +200,23 @@ endef
 $(eval $(call KernelPackage,iio-htu21))
 
 
+define KernelPackage/iio-ccs811
+  SUBMENU:=$(IIO_MENU)
+  DEPENDS:=+kmod-i2c-core +kmod-iio-core
+  TITLE:=AMS CCS811 VOC sensor
+  KCONFIG:= \
+       CONFIG_CCS811
+  FILES:= $(LINUX_DIR)/drivers/iio/chemical/ccs811.ko
+  AUTOLOAD:=$(call AutoLoad,56,ccs811)
+endef
+
+define KernelPackage/iio-ccs811/description
+  Support for the AMS CCS811 VOC (Volatile Organic Compounds) sensor
+endef
+
+$(eval $(call KernelPackage,iio-ccs811))
+
+
 define KernelPackage/iio-si7020
   SUBMENU:=$(IIO_MENU)
   DEPENDS:=+kmod-i2c-core +kmod-iio-core