base-files: disable LEDs if default state is undefined
authorDavid Bauer <mail@david-bauer.net>
Sun, 26 Jul 2020 20:37:53 +0000 (22:37 +0200)
committerDavid Bauer <mail@david-bauer.net>
Fri, 11 Sep 2020 15:34:54 +0000 (17:34 +0200)
Set the default state for LEDs to off. When a trigger is set, the
trigger will turn the LED automatically on.

Currently LEDs might stay on, e.g. when the LED trigger is set to a
netdev trigger and the interface is never activated or the 'none'
trigger is selected without setting the 'default' option to 0 and it's
set for the LED indicating the system running state.

Using off as a default value is also consistent with the documentation
in the OpenWrt wiki.

Signed-off-by: David Bauer <mail@david-bauer.net>
package/base-files/Makefile
package/base-files/files/etc/init.d/led

index 2419849a441f32cc5f0958efb668e2baf04c519d..73455174db4653fafa05bc45bd7b6c7fe51ec968 100644 (file)
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
 include $(INCLUDE_DIR)/feeds.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=228
+PKG_RELEASE:=229
 PKG_FLAGS:=nonshared
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
index 932a69a82be5f0a953ba94ae152130abd6031d57..277fb4e76f7eb9bf812ad4f0831edb8ff4f1189c 100755 (executable)
@@ -21,7 +21,7 @@ load_led() {
        config_get dev $1 dev
        config_get ports $1 port
        config_get mode $1 mode
-       config_get_bool default $1 default "nil"
+       config_get_bool default $1 default "0"
        config_get delayon $1 delayon
        config_get delayoff $1 delayoff
        config_get interval $1 interval "50"