openssl: update to version 1.0.2p
authorHauke Mehrtens <hauke@hauke-m.de>
Wed, 15 Aug 2018 20:17:11 +0000 (22:17 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 15 Aug 2018 20:42:39 +0000 (22:42 +0200)
This fixes the following security problems:
 * CVE-2018-0732: Client DoS due to large DH parameter
 * CVE-2018-0737: Cache timing vulnerability in RSA Key Generation

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/libs/openssl/Makefile
package/libs/openssl/patches/150-no_engines.patch
package/libs/openssl/patches/200-parallel_build.patch

index 8409730d706f2a8611471f2d7d87602dc1fe78c5..b64a51d6d31438234da6a08a081e414d5f306efa 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssl
 PKG_BASE:=1.0.2
-PKG_BUGFIX:=o
+PKG_BUGFIX:=p
 PKG_VERSION:=$(PKG_BASE)$(PKG_BUGFIX)
 PKG_RELEASE:=1
 PKG_USE_MIPS16:=0
@@ -24,7 +24,7 @@ PKG_SOURCE_URL:= \
        http://gd.tuwien.ac.at/infosys/security/openssl/source/ \
        http://www.openssl.org/source/ \
        http://www.openssl.org/source/old/$(PKG_BASE)/
-PKG_HASH:=ec3f5c9714ba0fd45cb4e087301eb1336c317e0d20b575a125050470e8089e4d
+PKG_HASH:=50a98e07b1a89eb8f6a99477f262df71c6fa7bef77df4dc83025a2845c827d00
 
 PKG_LICENSE:=OpenSSL
 PKG_LICENSE_FILES:=LICENSE
index 102e7a3272967ca5f7ecf2c76a89d3620d5a8fed..a518a00496605edef7795f40feeb6aa7c4f41dfc 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Configure
 +++ b/Configure
-@@ -2136,6 +2136,11 @@ EOF
+@@ -2144,6 +2144,11 @@ EOF
        close(OUT);
    }
    
index 0616551b6e75c7cf93a3bf5aed94d9528ce9a55e..37134e403038bb03f15fc2c0aa1b57a027231678 100644 (file)
  
  apps:
        @(cd ..; $(MAKE) DIRS=apps all)
-@@ -586,7 +586,7 @@ $(DTLSTEST)$(EXE_EXT): $(DTLSTEST).o ssl
+@@ -593,7 +593,7 @@ $(DTLSTEST)$(EXE_EXT): $(DTLSTEST).o ssl
  #     fi
  
  dummytest$(EXE_EXT): dummytest.o $(DLIBCRYPTO)