kernel: bump 4.9 to 4.9.138
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 21 Nov 2018 09:43:44 +0000 (10:43 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 22 Nov 2018 09:49:01 +0000 (10:49 +0100)
Refreshed all patches.

Compile-tested: ar71xx, layerscape
Runtime-tested: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/pending-4.9/170-MIPS-PCI-add-controllers-before-the-specified-head.patch
target/linux/generic/pending-4.9/330-MIPS-kexec-Accept-command-line-parameters-from-users.patch

index 8e52c9b70effc2e6a82ac23f462d8454ec13647d..8a0999abcdc469ac9db87eac261d3b45546020d0 100644 (file)
@@ -3,11 +3,11 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .125
 LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .125
-LINUX_VERSION-4.9 = .137
+LINUX_VERSION-4.9 = .138
 LINUX_VERSION-4.14 = .81
 
 LINUX_KERNEL_HASH-3.18.125 = 708433b360efd8623f7303b721ffb0e7c59cbe8552f1a3f4c0d980a12b4ed90e
 LINUX_VERSION-4.14 = .81
 
 LINUX_KERNEL_HASH-3.18.125 = 708433b360efd8623f7303b721ffb0e7c59cbe8552f1a3f4c0d980a12b4ed90e
-LINUX_KERNEL_HASH-4.9.137 = 6db2512a9094bf4c830124641d1275635600b052962a7db3556da18914ea2589
+LINUX_KERNEL_HASH-4.9.138 = 92301242601d50854b173a3fdec318480e24fc86f32102003a9ed7108fab21b7
 LINUX_KERNEL_HASH-4.14.81 = 4b36dfd053844ef0617799d432eed67aa4795d3403216d6789288aa7a0e75bde
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 LINUX_KERNEL_HASH-4.14.81 = 4b36dfd053844ef0617799d432eed67aa4795d3403216d6789288aa7a0e75bde
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 3eed80e71427b6feb77f210dcc6f2444e3cc4078..33f28912a23c727697f78c51bbda787f703e0eac 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: Mathias Kresin <dev@kresin.me>
 
 --- a/arch/mips/pci/pci-legacy.c
 +++ b/arch/mips/pci/pci-legacy.c
 
 --- a/arch/mips/pci/pci-legacy.c
 +++ b/arch/mips/pci/pci-legacy.c
-@@ -190,7 +190,7 @@ void register_pci_controller(struct pci_
+@@ -194,7 +194,7 @@ void register_pci_controller(struct pci_
        }
  
        INIT_LIST_HEAD(&hose->list);
        }
  
        INIT_LIST_HEAD(&hose->list);
index ff85a13fdae0b697081dd61423104e653a599099..c7abd99b3b179203c6312f0578fa4318345ac49b 100644 (file)
@@ -181,7 +181,7 @@ Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
  
        /*
         * The generic kexec code builds a page list with physical
  
        /*
         * The generic kexec code builds a page list with physical
-@@ -99,15 +214,16 @@ machine_kexec(struct kimage *image)
+@@ -102,15 +217,16 @@ machine_kexec(struct kimage *image)
        /*
         * we do not want to be bothered.
         */
        /*
         * we do not want to be bothered.
         */