build: drop clang wrapper
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Sat, 28 Nov 2020 17:38:54 +0000 (17:38 +0000)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Tue, 5 Jan 2021 08:59:59 +0000 (08:59 +0000)
clang's gcc emulation does the right thing with -print-file-name now,
drop the wrapper

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
include/toplevel.mk
scripts/clang-gcc-wrapper [deleted file]

index 4003b4824182bf7d3f4243e68c3d4da806d4fc76..d3500ef58f098c53f37ceb5394c1d7e84a9243c3 100644 (file)
@@ -19,7 +19,6 @@ else
   SOURCE_DATE_EPOCH:=$(shell $(TOPDIR)/scripts/get_source_date_epoch.sh)
 endif
 
-HOSTCC ?= $(CC)
 export REVISION
 export SOURCE_DATE_EPOCH
 export GIT_CONFIG_PARAMETERS='core.autocrlf=false'
@@ -59,13 +58,6 @@ export PATH:=$(path)
 
 unexport TAR_OPTIONS
 
-ifneq ($(shell $(HOSTCC) 2>&1 | grep clang),)
-  export HOSTCC_REAL?=$(HOSTCC)
-  export HOSTCC_WRAPPER:=$(TOPDIR)/scripts/clang-gcc-wrapper
-else
-  export HOSTCC_WRAPPER:=$(HOSTCC)
-endif
-
 ifeq ($(FORCE),)
   .config scripts/config/conf scripts/config/mconf: staging_dir/host/.prereq-build
 endif
@@ -115,7 +107,7 @@ endif
 scripts/config/%onf: CFLAGS+= -O2
 scripts/config/%onf:
        @$(_SINGLE)$(SUBMAKE) $(if $(findstring s,$(OPENWRT_VERBOSE)),,-s) \
-               -C scripts/config $(notdir $@) CC="$(HOSTCC_WRAPPER)"
+               -C scripts/config $(notdir $@)
 
 $(eval $(call rdep,scripts/config,scripts/config/mconf))
 
diff --git a/scripts/clang-gcc-wrapper b/scripts/clang-gcc-wrapper
deleted file mode 100755 (executable)
index 9e66841..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-#!/bin/sh
-_cc="${HOSTCC_REAL:-gcc}"
-case "$1" in
-       -print-file-name=*)
-               dirs="$($_cc -print-search-dirs | grep -m1 libraries | sed -e 's,:, ,' -e 's,.* =,,')"
-               dirs="$dirs /usr/lib /usr/local/lib"
-               find $dirs -name "${1#*=}" | head -n1
-       ;;
-       *)
-               exec $_cc "$@"
-       ;;
-esac