openvpn: add support to start/stop single instances
authorMartin Schiller <ms@dev.tdt.de>
Mon, 9 Oct 2017 08:12:04 +0000 (10:12 +0200)
committerHans Dedecker <dedeckeh@gmail.com>
Mon, 13 Nov 2017 20:37:24 +0000 (21:37 +0100)
Signed-off-by: Martin Schiller <ms@dev.tdt.de>
Signed-off-by: Hans Dedecker <dedeckeh@gmail.com> (PKG_RELEASE increase)
package/network/services/openvpn/Makefile
package/network/services/openvpn/files/openvpn.init

index 9d8f047613ddd41a954c49d12dc544fbb05188e7..fee0296ed4f936ca0a083879380716568f74423c 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=openvpn
 
 PKG_VERSION:=2.4.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_URL:=\
        https://build.openvpn.net/downloads/releases/ \
index 98c1710f03f4bd4e0a70806fa13af140096ca57e..ab4f7dba0d4e2421e543591317c4a8d576e3eab3 100644 (file)
@@ -60,7 +60,7 @@ openvpn_add_instance() {
        local dir="$2"
        local conf="$3"
 
-       procd_open_instance
+       procd_open_instance "$name"
        procd_set_param command "$PROG" \
                --syslog "openvpn($name)" \
                --status "/var/run/openvpn.$name.status" \
@@ -103,28 +103,47 @@ start_instance() {
 }
 
 start_service() {
+       local instance="$1"
+       local instance_found=0
+
+       config_cb() {
+               local type="$1"
+               local name="$2"
+               if [ "$type" = "openvpn" ]; then
+                       if [ -n "$instance" -a "$instance" = "$name" ]; then
+                               instance_found=1
+                       fi
+               fi
+       }
+
        . /usr/share/openvpn/openvpn.options
        config_load 'openvpn'
-       config_foreach start_instance 'openvpn'
 
-       local path name
-       for path in /etc/openvpn/*.conf; do
-               if [ -f "$path" ]; then
-                       name="${path##*/}"; name="${name%.conf}"
+       if [ -n "$instance" ]; then
+               [ "$instance_found" -gt 0 ] || return
+               start_instance "$instance"
+       else
+               config_foreach start_instance 'openvpn'
 
-                       # don't start configs again that are already started by uci
-                       if echo "$UCI_STARTED" | grep -qxF "$path"; then
-                               continue
+               local path name
+               for path in /etc/openvpn/*.conf; do
+                       if [ -f "$path" ]; then
+                               name="${path##*/}"; name="${name%.conf}"
 
-                       # don't start configs which are set to disabled in uci
-                       elif echo "$UCI_DISABLED" | grep -qxF "$path"; then
-                               logger -t openvpn "$name.conf is disabled in /etc/config/openvpn"
-                               continue
-                       fi
+                               # don't start configs again that are already started by uci
+                               if echo "$UCI_STARTED" | grep -qxF "$path"; then
+                                       continue
 
-                       openvpn_add_instance "$name" "${path%/*}" "$path"
-               fi
-       done
+                               # don't start configs which are set to disabled in uci
+                               elif echo "$UCI_DISABLED" | grep -qxF "$path"; then
+                                       logger -t openvpn "$name.conf is disabled in /etc/config/openvpn"
+                                       continue
+                               fi
+
+                               openvpn_add_instance "$name" "${path%/*}" "$path"
+                       fi
+               done
+       fi
 }
 
 service_triggers() {