ar71xx: increase kernel partition size for CPE/WBS 210/510
authorMatthias Schiffer <mschiffer@universe-factory.net>
Tue, 10 Apr 2018 16:14:41 +0000 (18:14 +0200)
committerMatthias Schiffer <mschiffer@universe-factory.net>
Tue, 10 Apr 2018 16:29:19 +0000 (18:29 +0200)
Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
target/linux/ar71xx/image/generic-tp-link.mk
tools/firmware-utils/src/tplink-safeloader.c

index 9054f1c7da44c75d0862b9b578ffef9635aba4bb..b3b5fdf19015828b711a9ef8fe641d4dcb5f0cf2 100644 (file)
@@ -144,7 +144,7 @@ TARGET_DEVICES += archer-c7-v4
 define Device/cpe510-520-v1
   DEVICE_TITLE := TP-LINK CPE510/520 v1
   DEVICE_PACKAGES := rssileds
 define Device/cpe510-520-v1
   DEVICE_TITLE := TP-LINK CPE510/520 v1
   DEVICE_PACKAGES := rssileds
-  MTDPARTS := spi0.0:128k(u-boot)ro,64k(partition-table)ro,64k(product-info)ro,1536k(kernel),6144k(rootfs),192k(config)ro,64k(ART)ro,7680k@0x40000(firmware)
+  MTDPARTS := spi0.0:128k(u-boot)ro,64k(partition-table)ro,64k(product-info)ro,1792k(kernel),5888k(rootfs),192k(config)ro,64k(ART)ro,7680k@0x40000(firmware)
   IMAGE_SIZE := 7680k
   BOARDNAME := CPE510
   TPLINK_BOARD_ID := CPE510
   IMAGE_SIZE := 7680k
   BOARDNAME := CPE510
   TPLINK_BOARD_ID := CPE510
index 60f08f4a76477f9056acd279cc50f0c29fa183da..997ffcb09c15241b0dd7303e9bff1c8daf885a1a 100644 (file)
@@ -140,8 +140,8 @@ static struct device_info boards[] = {
                        {"default-mac", 0x30000, 0x00020},
                        {"product-info", 0x31100, 0x00100},
                        {"signature", 0x32000, 0x00400},
                        {"default-mac", 0x30000, 0x00020},
                        {"product-info", 0x31100, 0x00100},
                        {"signature", 0x32000, 0x00400},
-                       {"os-image", 0x40000, 0x180000},
-                       {"file-system", 0x1c0000, 0x5f0000},
+                       {"os-image", 0x40000, 0x1c0000},
+                       {"file-system", 0x200000, 0x5b0000},
                        {"soft-version", 0x7b0000, 0x00100},
                        {"support-list", 0x7b1000, 0x00400},
                        {"user-config", 0x7c0000, 0x10000},
                        {"soft-version", 0x7b0000, 0x00100},
                        {"support-list", 0x7b1000, 0x00400},
                        {"user-config", 0x7c0000, 0x10000},
@@ -178,8 +178,8 @@ static struct device_info boards[] = {
                        {"default-mac", 0x30000, 0x00020},
                        {"product-info", 0x31100, 0x00100},
                        {"signature", 0x32000, 0x00400},
                        {"default-mac", 0x30000, 0x00020},
                        {"product-info", 0x31100, 0x00100},
                        {"signature", 0x32000, 0x00400},
-                       {"os-image", 0x40000, 0x180000},
-                       {"file-system", 0x1c0000, 0x5f0000},
+                       {"os-image", 0x40000, 0x1c0000},
+                       {"file-system", 0x200000, 0x5b0000},
                        {"soft-version", 0x7b0000, 0x00100},
                        {"support-list", 0x7b1000, 0x00400},
                        {"user-config", 0x7c0000, 0x10000},
                        {"soft-version", 0x7b0000, 0x00100},
                        {"support-list", 0x7b1000, 0x00400},
                        {"user-config", 0x7c0000, 0x10000},
@@ -210,8 +210,8 @@ static struct device_info boards[] = {
                        {"default-mac", 0x30000, 0x00020},
                        {"product-info", 0x31100, 0x00100},
                        {"signature", 0x32000, 0x00400},
                        {"default-mac", 0x30000, 0x00020},
                        {"product-info", 0x31100, 0x00100},
                        {"signature", 0x32000, 0x00400},
-                       {"os-image", 0x40000, 0x180000},
-                       {"file-system", 0x1c0000, 0x5f0000},
+                       {"os-image", 0x40000, 0x1c0000},
+                       {"file-system", 0x200000, 0x5b0000},
                        {"soft-version", 0x7b0000, 0x00100},
                        {"support-list", 0x7b1000, 0x00400},
                        {"user-config", 0x7c0000, 0x10000},
                        {"soft-version", 0x7b0000, 0x00100},
                        {"support-list", 0x7b1000, 0x00400},
                        {"user-config", 0x7c0000, 0x10000},
@@ -242,8 +242,8 @@ static struct device_info boards[] = {
                        {"default-mac", 0x30000, 0x00020},
                        {"product-info", 0x31100, 0x00100},
                        {"signature", 0x32000, 0x00400},
                        {"default-mac", 0x30000, 0x00020},
                        {"product-info", 0x31100, 0x00100},
                        {"signature", 0x32000, 0x00400},
-                       {"os-image", 0x40000, 0x180000},
-                       {"file-system", 0x1c0000, 0x5f0000},
+                       {"os-image", 0x40000, 0x1c0000},
+                       {"file-system", 0x200000, 0x5b0000},
                        {"soft-version", 0x7b0000, 0x00100},
                        {"support-list", 0x7b1000, 0x00400},
                        {"user-config", 0x7c0000, 0x10000},
                        {"soft-version", 0x7b0000, 0x00100},
                        {"support-list", 0x7b1000, 0x00400},
                        {"user-config", 0x7c0000, 0x10000},