enable openssl engine support on ixp4xx
authorImre Kaloz <kaloz@openwrt.org>
Sat, 12 Jul 2008 15:42:00 +0000 (15:42 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Sat, 12 Jul 2008 15:42:00 +0000 (15:42 +0000)
SVN-Revision: 11788

package/openssl/Makefile

index 9fca6b14986b975a4d3fd9941b0dcee2c81b0434..6eafc7ed7d71239c404dd745fa5664c0ac9a1d7d 100644 (file)
@@ -67,8 +67,13 @@ endef
 
 OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc2 no-rc5 no-sha0 no-smime \
                                        no-rmd160 no-aes192 no-ripemd no-camellia no-ans1 no-krb5
+ifeq ($(BOARD),ixp4xx)
+OPENSSL_OPTIONS:= shared no-ec no-err no-fips no-hw no-threads zlib-dynamic \
+                                       no-sse2 no-perlasm
+else
 OPENSSL_OPTIONS:= shared no-ec no-err no-fips no-hw no-threads zlib-dynamic \
                                        no-engines no-sse2 no-perlasm
+endif
 
 
 define Build/Configure