add support for Package/<pkgname>/description - old format still supported, but depre...
authorFelix Fietkau <nbd@openwrt.org>
Tue, 10 Oct 2006 15:45:36 +0000 (15:45 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 10 Oct 2006 15:45:36 +0000 (15:45 +0000)
SVN-Revision: 5015

openwrt/include/package.mk
openwrt/package/busybox/Makefile

index 181ea32b6e91a25b99f5fce26ff013b403823b3d..7ae95f8fe8699206c12083661b3910969d4f9f22 100644 (file)
@@ -169,6 +169,8 @@ define BuildPackage
        echo "Default: $(DEFAULT)";
     endif
 
        echo "Default: $(DEFAULT)";
     endif
 
+       $(call shexport,Package/$(1)/description)
+
     DUMPINFO += \
        if [ "$$$$PREREQ_CHECK" = 1 ]; then echo "Prereq-Check: 1"; fi; \
        echo "Version: $(VERSION)"; \
     DUMPINFO += \
        if [ "$$$$PREREQ_CHECK" = 1 ]; then echo "Prereq-Check: 1"; fi; \
        echo "Version: $(VERSION)"; \
@@ -176,7 +178,12 @@ define BuildPackage
        echo "Build-Depends: $(PKG_BUILDDEP)"; \
        echo "Category: $(CATEGORY)"; \
        echo "Title: $(TITLE)"; \
        echo "Build-Depends: $(PKG_BUILDDEP)"; \
        echo "Category: $(CATEGORY)"; \
        echo "Title: $(TITLE)"; \
-       echo "Description: $(DESCRIPTION)" | sed -e 's,\\,\n,g'; \
+       if isset $(call shvar,Package/$(1)/description); then \
+               echo -n "Description: "; \
+               getvar $(call shvar,Package/$(1)/description); \
+       else \
+               echo "Description: $(DESCRIPTION)" | sed -e 's,\\,\n,g'; \
+       fi;
        
     ifneq ($(URL),)
       DUMPINFO += \
        
     ifneq ($(URL),)
       DUMPINFO += \
index f56d2462d74658b92bfc5f0f7288e08b6dcb470c..05174a32bda0dd0b8bb2cfeb065de2bcabf6ed9d 100644 (file)
@@ -26,13 +26,15 @@ define Package/busybox
   CATEGORY:=Base system
   DEFAULT:=y
   TITLE:=Core utilities for embedded Linux
   CATEGORY:=Base system
   DEFAULT:=y
   TITLE:=Core utilities for embedded Linux
-  DESCRIPTION:=\
-       The Swiss Army Knife of embedded Linux. \\\
-       It slices, it dices, it makes Julian Fries.
   URL:=http://busybox.net/
   MENU:=1
 endef
 
   URL:=http://busybox.net/
   MENU:=1
 endef
 
+define Package/busybox/description
+The Swiss Army Knife of embedded Linux.
+       It slices, it dices, it makes Julian Fries.
+endef
+
 define Package/busybox/config
        menu "Configuration"
                depends on PACKAGE_busybox
 define Package/busybox/config
        menu "Configuration"
                depends on PACKAGE_busybox