ltq-vdsl-app: fix -Wundef warnings
authorMathias Kresin <dev@kresin.me>
Tue, 16 Feb 2021 18:35:07 +0000 (19:35 +0100)
committerMathias Kresin <dev@kresin.me>
Sun, 28 Feb 2021 23:19:58 +0000 (00:19 +0100)
The following warnings are shown during build:

/usr/include/vdsl/cmv_message_format.h:33:6: warning: "MEI_SUPPORT_DEBUG_STREAMS" is not defined, evaluates to 0 [-Wundef]
 #if (MEI_SUPPORT_DEBUG_STREAMS == 1)
      ^~~~~~~~~~~~~~~~~~~~~~~~~
/usr/include/vdsl/drv_mei_cpe_interface.h:2256:6: warning: "MEI_SUPPORT_OPTIMIZED_FW_DL" is not defined, evaluates to 0 [-Wundef]
 #if (MEI_SUPPORT_OPTIMIZED_FW_DL == 1)
      ^~~~~~~~~~~~~~~~~~~~~~~~~~~

The headers are provided by the MEI driver, but the defines are never
set by the vdsl app. While the struct with the
MEI_SUPPORT_OPTIMIZED_FW_DL conditional isn't used by the vdsl app,
however CMV_USED_PAYLOAD_8BIT_SIZE which value depends on
MEI_SUPPORT_DEBUG_STREAMS is.

Since the MEI driver doesn't provide an autogenerated header with
compile flags, the flags are hardcoded for the vdsl app.

Set them for the MEI driver as well, to indicate a relation to the
values used for the vdsl app and to be not surprised by a changed
default in case the MEI driver gets updated. Use the current default
values defined in the MEI driver.

Signed-off-by: Mathias Kresin <dev@kresin.me>
package/kernel/lantiq/ltq-vdsl-mei/Makefile
package/network/config/ltq-vdsl-app/Makefile

index 8e52d20a722395f96097ec2196af36fafe5e158a..796918549a0ec83d339a9b52bb75ac1c6571cc89 100644 (file)
@@ -56,6 +56,15 @@ MAKE_FLAGS += \
        $(KERNEL_MAKE_FLAGS) \
        SHELL="$(BASH)"
 
+# ltq-vdsl-app uses a header provided by the MEI driver which has some
+# conditionals.
+# Define the conditionals here to have the same view on both sides. If you
+# change them, you need to change them for the ltq-vdsl-app as well
+MEI_DRV_CFLAGS = \
+       -DMEI_DRV_ATM_PTM_INTERFACE_ENABLE=1 \
+       -DMEI_SUPPORT_DEBUG_STREAMS=1 \
+       -DMEI_SUPPORT_OPTIMIZED_FW_DL=1
+
 CONFIGURE_ARGS += \
        --enable-kernelincl="$(LINUX_DIR)/include" \
        --enable-device=vr9 \
@@ -65,7 +74,7 @@ CONFIGURE_ARGS += \
        --enable-error_print \
        --enable-ifxos-include="-I$(STAGING_DIR)/usr/include/ifxos/" \
        --enable-ifxos-library="-L$(STAGING_DIR)/usr/lib" \
-       --enable-add_drv_cflags="-DMEI_DRV_ATM_PTM_INTERFACE_ENABLE=1" \
+       --enable-add_drv_cflags="$(MEI_DRV_CFLAGS)" \
        --enable-linux-26 \
        --enable-kernelbuild="$(LINUX_DIR)" \
        --enable-drv_test_appl=yes \
index 0968811984dace124730c0a9eef3091f00dabcaa..7665f37514c3a7777f5760843446b4b32c8e66a5 100644 (file)
@@ -36,6 +36,18 @@ define Package/ltq-vdsl-app/description
   Userland tool needed to control Lantiq VDSL CPE
 endef
 
+# ltq-vdsl-app uses a header provided by the MEI driver which has some
+# conditionals.
+#
+# Define them here with the default values they would get in the MEI driver,
+# have the same view on both sides.
+#
+# If you change them, you need to change them for the ltq-vdsl-app as well
+VDSL_APP_CFLAGS = \
+       -DMAX_CLI_PIPES=1 \
+       -DMEI_SUPPORT_DEBUG_STREAMS=1 \
+       -DMEI_SUPPORT_OPTIMIZED_FW_DL=1
+
 CONFIGURE_ARGS += \
        --enable-vrx \
        --enable-vrx-device=vr9 \
@@ -44,10 +56,10 @@ CONFIGURE_ARGS += \
        --enable-ifxos \
        --enable-ifxos-include="-I$(STAGING_DIR)/usr/include/ifxos" \
        --enable-ifxos-library="-I$(STAGING_DIR)/usr/lib" \
-       --enable-add-appl-cflags="-DMAX_CLI_PIPES=1"  \
+       --enable-add-appl-cflags="$(VDSL_APP_CFLAGS)"  \
        --enable-debug \
        --disable-dti \
-       --with-channels-per-line="1" \
+       --with-channels-per-line="1"
 
 #CONFIGURE_ARGS += --enable-model=full
 #CONFIGURE_ARGS += --enable-model=lite