uclient: update to latest git HEAD
authorJo-Philipp Wich <jo@mein.io>
Fri, 3 Aug 2018 21:50:29 +0000 (23:50 +0200)
committerJo-Philipp Wich <jo@mein.io>
Fri, 3 Aug 2018 21:50:29 +0000 (23:50 +0200)
f2573da uclient-fetch: use package name pattern in message for missing SSL library
9fd8070 uclient-fetch: Check for nullpointer returned by uclient_get_url_filename
f41ff60 uclient-http: basic auth: Handle memory allocation failure
a73b23b uclient-http: auth digest: Handle multiple possible memory allocation failures
66fb58d uclient-http: Handle memory allocation failure
2ac991b uclient: Handle memory allocation failure for url
63beea4 uclient-http: Implement error handling for header-sending
eb850df uclient-utils: Handle memory allocation failure for url file name
ae1c656 uclient-http: Close ustream file handle only if allocated

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/libs/uclient/Makefile

index f0c08a3233ffd8a2dc8e112d3efa6c6c7f6ed094..888fce3e2aa62042c5d4c83c7730bc5c46fd7e7f 100644 (file)
@@ -5,9 +5,9 @@ PKG_RELEASE=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/uclient.git
-PKG_SOURCE_DATE:=2017-11-02
-PKG_SOURCE_VERSION:=4b87d83160fec70d50b7fcd736a8c538c28a016c
-PKG_MIRROR_HASH:=4bbb4d5f295ebdcd67fec87a6794168bea2176a42cb2907c47d8566fb33dafb3
+PKG_SOURCE_DATE:=2018-08-03
+PKG_SOURCE_VERSION:=ae1c656ff041c6f1ccb37b070fa261e0d71f2b12
+PKG_MIRROR_HASH:=e88c92f880d3c1cf4162f62c4eeb8986baa8d73772e51eed3a60a8346aeb1b7c
 CMAKE_INSTALL:=1
 
 PKG_BUILD_DEPENDS:=ustream-ssl