Improve n810 profile
authorMichael Büsch <mb@bu3sch.de>
Thu, 26 Aug 2010 19:54:08 +0000 (19:54 +0000)
committerMichael Büsch <mb@bu3sch.de>
Thu, 26 Aug 2010 19:54:08 +0000 (19:54 +0000)
SVN-Revision: 22817

target/linux/omap24xx/Makefile
target/linux/omap24xx/profiles/100-n810.mk
target/linux/omap24xx/profiles/110-n810-gui.mk [new file with mode: 0644]

index 901d24b5d1c0d57db23019b484c15ad3cd780897..29be9e1b8e776156a3d7ae474b967c9159d388b1 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=omap24xx
 BOARDNAME:=TI OMAP-24xx
-FEATURES:=squashfs jffs2 usb usbgadget
+FEATURES:=targz squashfs jffs2 usb usbgadget display gpio audio
 
 LINUX_VERSION:=2.6.35.3
 
index 6eddc0501dc8aa4b59ac845d0b13268a5f07f0fd..f424b9723b5b0af841e5bca43330475c384fe3f4 100644 (file)
@@ -5,13 +5,21 @@
 # See /LICENSE for more information.
 #
 
-define Profile/n810
-  NAME:=Nokia n810
-  PACKAGES:=
+define Profile/n810-base
+  NAME:=Nokia n810 (base)
+  PACKAGES:= \
+       block-hotplug \
+       gpsd \
+       ip iw wireless-tools kmod-p54-spi wpa-supplicant \
+       dnsmasq dropbear \
+       kmod-fs-vfat kmod-fs-msdos \
+       kmod-input-evdev \
+       kmod-leds-gpio \
+       kmod-usb-tahvo kmod-usb-eth-gadget kmod-usb-net kmod-usb-net-cdc-ether
 endef
 
-define Profile/n810/Description
-       Package set compatible with Nokia n810 hardware
+define Profile/n810-base/Description
+       Minimal package set for Nokia n810 hardware.
 endef
-$(eval $(call Profile,n810))
+$(eval $(call Profile,n810-base))
 
diff --git a/target/linux/omap24xx/profiles/110-n810-gui.mk b/target/linux/omap24xx/profiles/110-n810-gui.mk
new file mode 100644 (file)
index 0000000..b04db3c
--- /dev/null
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/n810-gui
+  $(call Profile/n810-base)
+  NAME:=Nokia n810 (GUI)
+  PACKAGES+= \
+       xserver-xorg xinit xauth xterm \
+       xf86-video-omapfb xf86-input-tslib xf86-input-evdev \
+       openbox lxpanel \
+       pwrtray
+endef
+
+define Profile/n810-gui/Description
+       Graphical user interface package set for Nokia n810 hardware.
+endef
+$(eval $(call Profile,n810-gui))
+