ath79: combine UniFi AC dual firmware-partitions
authorDavid Bauer <mail@david-bauer.net>
Thu, 17 Nov 2022 21:53:33 +0000 (22:53 +0100)
committerDavid Bauer <mail@david-bauer.net>
Sat, 7 Jan 2023 00:32:58 +0000 (01:32 +0100)
In order to maximize the available space on UniFi AC boards using a
dual-image partition layout, combine the two OS partitions into a single
partition.

This allows users to access more usable space for additional packages.

Don't limit the usable image size to the size of a single OS partition.
The initial installation has to be done with an older version of OpenWrt
in case the generated image exceeds the space of a single kernel
partition in the future.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ath79/dts/qca9563_ubnt_unifiac.dtsi
target/linux/ath79/image/generic-ubnt.mk

index 2e407c348642cf5145f79c15288856fa141b0512..6704ec983b0beed5421a59f663cf8db6d650f559 100644 (file)
                        };
 
                        partition@70000 {
+                               /* Combine kernel0 & kernel1 */
                                label = "firmware";
-                               reg = <0x070000 0x790000>;
+                               reg = <0x070000 0xf20000>;
                                compatible = "denx,uimage";
                        };
 
-                       partition@800000 {
-                               label = "kernel1";
-                               reg = <0x800000 0x790000>;
-                               read-only;
-                       };
-
                        partition@f90000 {
                                label = "bs";
                                reg = <0xf90000 0x020000>;
index bed043c3a780c337590d359dc044e93cef60249e..8eeaa8de3e46acd9e712550d67b86a2224ca4145 100644 (file)
@@ -229,7 +229,7 @@ TARGET_DEVICES += ubnt_unifi-ap-lr
 define Device/ubnt_unifiac
   DEVICE_VENDOR := Ubiquiti
   SOC := qca9563
-  IMAGE_SIZE := 7744k
+  IMAGE_SIZE := 15488k
   DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
 endef