ar71xx: create a proper default profile for the mikrotik subtarget, drop other profiles
authorFelix Fietkau <nbd@nbd.name>
Sat, 7 Jan 2017 19:54:42 +0000 (20:54 +0100)
committerFelix Fietkau <nbd@nbd.name>
Wed, 1 Feb 2017 13:58:52 +0000 (14:58 +0100)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
target/linux/ar71xx/mikrotik/profiles/00-default.mk [new file with mode: 0644]
target/linux/ar71xx/mikrotik/profiles/01-minimal.mk [deleted file]
target/linux/ar71xx/mikrotik/profiles/02-ath5k.mk [deleted file]

diff --git a/target/linux/ar71xx/mikrotik/profiles/00-default.mk b/target/linux/ar71xx/mikrotik/profiles/00-default.mk
new file mode 100644 (file)
index 0000000..f3dfeef
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+       NAME:=Default Profile
+       PACKAGES:= \
+               kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport nand-utils
+endef
+
+define Profile/Default/Description
+       Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))
diff --git a/target/linux/ar71xx/mikrotik/profiles/01-minimal.mk b/target/linux/ar71xx/mikrotik/profiles/01-minimal.mk
deleted file mode 100644 (file)
index a334977..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/DefaultNoWifi
-       NAME:=Default Profile (no WiFi)
-       PACKAGES:=
-       PRIORITY := 2
-endef
-
-define Profile/DefaultNoWifi/Description
-       Default package set compatible with most boards.
-endef
-$(eval $(call Profile,DefaultNoWifi))
diff --git a/target/linux/ar71xx/mikrotik/profiles/02-ath5k.mk b/target/linux/ar71xx/mikrotik/profiles/02-ath5k.mk
deleted file mode 100644 (file)
index fa304b7..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2009-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Ath5k
-       NAME:=Atheros WiFi (ath5k)
-       PACKAGES:=kmod-ath5k -kmod-ath9k
-       PRIORITY := 3
-endef
-
-define Profile/Ath5k/Description
-       Package set compatible with hardware using Atheros WiFi cards.
-endef
-$(eval $(call Profile,Ath5k))