ipq806x: define KERNEL_SIZE in KB instead of byte for the image generation
authorStefan Lippers-Hollmann <s.l-h@gmx.de>
Fri, 18 May 2018 02:23:01 +0000 (04:23 +0200)
committerJohn Crispin <john@phrozen.org>
Thu, 24 May 2018 15:24:31 +0000 (17:24 +0200)
Signed-off-by: Stefan Lippers-Hollmann <s.l-h@gmx.de>
(cherry picked from commit 05f53eecca5e1b28706ef074477a55917ed6deb1)

target/linux/ipq806x/image/Makefile

index 68b039b3aecc607a2b41e2556edadeb2a69994d5..ac579919614b8c0c360a62bfe999ed2ff3360ab1 100644 (file)
@@ -104,7 +104,7 @@ TARGET_DEVICES += linksys_ea8500
 define Device/netgear_d7800
        $(call Device/DniImage)
        DEVICE_DTS := qcom-ipq8064-d7800
-       KERNEL_SIZE := 4194304
+       KERNEL_SIZE := 4096k
        NETGEAR_BOARD_ID := D7800
        NETGEAR_HW_ID := 29764958+0+128+512+4x4+4x4
        BLOCKSIZE := 128k
@@ -119,7 +119,7 @@ TARGET_DEVICES += netgear_d7800
 define Device/netgear_r7500
        $(call Device/DniImage)
        DEVICE_DTS := qcom-ipq8064-r7500
-       KERNEL_SIZE := 4194304
+       KERNEL_SIZE := 4096k
        NETGEAR_BOARD_ID := R7500
        NETGEAR_HW_ID := 29764841+0+128+256+3x3+4x4
        BLOCKSIZE := 128k
@@ -134,7 +134,7 @@ TARGET_DEVICES += netgear_r7500
 define Device/netgear_r7500v2
        $(call Device/DniImage)
        DEVICE_DTS := qcom-ipq8064-r7500v2
-       KERNEL_SIZE := 4194304
+       KERNEL_SIZE := 4096k
        NETGEAR_BOARD_ID := R7500v2
        NETGEAR_HW_ID := 29764958+0+128+512+3x3+4x4
        BLOCKSIZE := 128k
@@ -149,7 +149,7 @@ TARGET_DEVICES += netgear_r7500v2
 define Device/netgear_r7800
        $(call Device/DniImage)
        DEVICE_DTS := qcom-ipq8065-r7800
-       KERNEL_SIZE := 4194304
+       KERNEL_SIZE := 4096k
        NETGEAR_BOARD_ID := R7800
        NETGEAR_HW_ID := 29764958+0+128+512+4x4+4x4+cascade
        BLOCKSIZE := 128k
@@ -215,7 +215,7 @@ define Device/tplink_vr2600v
        KERNEL_SUFFIX := -uImage
        KERNEL = kernel-bin | append-dtb | uImage none
        KERNEL_NAME := zImage
-       KERNEL_SIZE := 3145728
+       KERNEL_SIZE := 3072k
        DEVICE_DTS := qcom-ipq8064-vr2600v
        BLOCKSIZE := 128k
        PAGESIZE := 2048