build: ensure PKG_INFO_DIR exists before trying to use it
authorJonas Gorski <jonas.gorski@gmail.com>
Sat, 28 Oct 2017 09:19:25 +0000 (11:19 +0200)
committerJonas Gorski <jonas.gorski@gmail.com>
Sat, 28 Oct 2017 09:19:25 +0000 (11:19 +0200)
PKG_INFO_DIR is only created at the finish step of the first package
build, but kernel modules now use it at the start. Doing a parallel build
could cause a kernel module to be the first package, breaking the build.

Fix this by ensuring the directory exists.

Fixes: 2e496876c60c ("kernel: collect module symvers for external modules")
Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
include/kernel.mk

index f2099add53a628de98fd5bf3651af575a21a27ec..f2d2a129d7f387d153d67051066c6cf5630b61f0 100644 (file)
@@ -133,6 +133,7 @@ define populate_module_symvers
 endef
 
 define collect_module_symvers
+       @mkdir -p $(PKG_INFO_DIR)
        for subdir in $(PKG_EXTMOD_SUBDIRS); do \
                grep -F $(PKG_BUILD_DIR) $(PKG_BUILD_DIR)/$$$$subdir/Module.symvers >> $(PKG_BUILD_DIR)/Module.symvers.tmp; \
        done; \