dnsmasq: backport missing braces fix
authorJo-Philipp Wich <jo@mein.io>
Wed, 30 Jan 2019 12:01:24 +0000 (13:01 +0100)
committerJo-Philipp Wich <jo@mein.io>
Wed, 30 Jan 2019 12:01:24 +0000 (13:01 +0100)
Fold upstream fix d2d4990
("Fix missing braces in 8eac67c0a15b673c8d27002c248651b308093e4") into
the already existing static lease fix patch.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/network/services/dnsmasq/Makefile
package/network/services/dnsmasq/patches/001-Fix-entries-in-etc-hosts-disabling-static-leases.patch

index f48847b9a30be5ba5902c3cf1dcd25d50c346356..e89ad19f5c57059f231fb1ab3a150ccacd136d23 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
 PKG_VERSION:=2.80
-PKG_RELEASE:=1.1
+PKG_RELEASE:=1.2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
index d641e4fbf116031d3d8cd8e2979b75a7d7d86b39..d74227fe7ca426bd0eccfc709de9d2c3579d0fbf 100644 (file)
@@ -20,9 +20,11 @@ Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
 
 --- a/src/dhcp-common.c
 +++ b/src/dhcp-common.c
-@@ -372,7 +372,11 @@ void dhcp_update_configs(struct dhcp_con
+@@ -371,8 +371,14 @@ void dhcp_update_configs(struct dhcp_con
+   int prot = AF_INET;
  
    for (config = configs; config; config = config->next)
++  {
      if (config->flags & CONFIG_ADDR_HOSTS)
 -      config->flags &= ~(CONFIG_ADDR | CONFIG_ADDR6 | CONFIG_ADDR_HOSTS);
 +      config->flags &= ~(CONFIG_ADDR | CONFIG_ADDR_HOSTS);
@@ -30,10 +32,11 @@ Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
 +    if (config->flags & CONFIG_ADDR6_HOSTS)
 +      config->flags &= ~(CONFIG_ADDR6 | CONFIG_ADDR6_HOSTS);
 +#endif
++  }
  
  #ifdef HAVE_DHCP6 
   again:  
-@@ -421,7 +425,7 @@ void dhcp_update_configs(struct dhcp_con
+@@ -421,7 +427,7 @@ void dhcp_update_configs(struct dhcp_con
                (!(conf_tmp = config_find_by_address6(configs, &crec->addr.addr.addr.addr6, 128, 0)) || conf_tmp == config))
              {
                memcpy(&config->addr6, &crec->addr.addr.addr.addr6, IN6ADDRSZ);