kernel: bump 5.10 to 5.10.72
authorJohn Audia <graysky@archlinux.us>
Sat, 9 Oct 2021 16:22:14 +0000 (12:22 -0400)
committerDaniel Golle <daniel@makrotopia.org>
Sat, 9 Oct 2021 23:09:22 +0000 (00:09 +0100)
All patches automatically rebased.

Build system: x86_64
Build-tested: bcm2711/RPi4B
Run-tested: bcm2711/RPi4B

Signed-off-by: John Audia <graysky@archlinux.us>
include/kernel-version.mk
target/linux/generic/hack-5.10/720-net-phy-add-aqr-phys.patch
target/linux/generic/pending-5.10/834-ledtrig-libata.patch
target/linux/oxnas/patches-5.10/999-libata-hacks.patch
target/linux/realtek/patches-5.10/306-gpio-add-legacy-rtl838x-driver.patch
target/linux/realtek/patches-5.10/704-include-linux-add-phy-hsgmii-mode.patch
target/linux/realtek/patches-5.10/705-include-linux-phy-increase-phy-address-number-for-rtl839x.patch

index caca1d64114c7638bd56bd61aa527e3eaaee0f59..0325cf318daead6a7e7c649fc7ceab1597df2a82 100644 (file)
@@ -7,10 +7,10 @@ ifdef CONFIG_TESTING_KERNEL
 endif
 
 LINUX_VERSION-5.4 = .150
-LINUX_VERSION-5.10 = .71
+LINUX_VERSION-5.10 = .72
 
 LINUX_KERNEL_HASH-5.4.150 = f424a9bbb05007f04c17f96a2e4f041a8001554a9060d2c291606e8a97c62aa2
-LINUX_KERNEL_HASH-5.10.71 = 02e688d27d963f0325f5cd30e383329cf00ab23db46d1586d6e848e3f992a497
+LINUX_KERNEL_HASH-5.10.72 = b4d635afe7646ac6a6617c738e747ba0a6006675cd9735d18f672f8b1fba4c7c
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 73afb245b4bc998adb4281485b9f03b99ab5bb57..4d4420aa2f0bfde1ec99ef721fc7ec8cbf56d341 100644 (file)
@@ -20,7 +20,7 @@ Signed-off-by: Birger Koblitz <git@birger-koblitz.de>
  
  #define MDIO_PHYXS_VEND_IF_STATUS             0xe812
  #define MDIO_PHYXS_VEND_IF_STATUS_TYPE_MASK   GENMASK(7, 3)
-@@ -330,6 +332,49 @@
+@@ -330,6 +332,49 @@ static int aqr107_read_rate(struct phy_d
        return 0;
  }
  
@@ -70,7 +70,7 @@ Signed-off-by: Birger Koblitz <git@birger-koblitz.de>
  static int aqr107_read_status(struct phy_device *phydev)
  {
        int val, ret;
-@@ -460,7 +505,7 @@
+@@ -460,7 +505,7 @@ static void aqr107_chip_info(struct phy_
        build_id = FIELD_GET(VEND1_GLOBAL_RSVD_STAT1_FW_BUILD_ID, val);
        prov_id = FIELD_GET(VEND1_GLOBAL_RSVD_STAT1_PROV_ID, val);
  
@@ -79,7 +79,7 @@ Signed-off-by: Birger Koblitz <git@birger-koblitz.de>
                   fw_major, fw_minor, build_id, prov_id);
  }
  
-@@ -632,6 +677,24 @@
+@@ -632,6 +677,24 @@ static struct phy_driver aqr_driver[] =
        .link_change_notify = aqr107_link_change_notify,
  },
  {
@@ -104,7 +104,7 @@ Signed-off-by: Birger Koblitz <git@birger-koblitz.de>
        PHY_ID_MATCH_MODEL(PHY_ID_AQCS109),
        .name           = "Aquantia AQCS109",
        .probe          = aqr107_probe,
-@@ -657,6 +720,24 @@
+@@ -657,6 +720,24 @@ static struct phy_driver aqr_driver[] =
        .ack_interrupt  = aqr_ack_interrupt,
        .read_status    = aqr_read_status,
  },
@@ -129,7 +129,7 @@ Signed-off-by: Birger Koblitz <git@birger-koblitz.de>
  };
  
  module_phy_driver(aqr_driver);
-@@ -667,8 +748,10 @@
+@@ -667,8 +748,10 @@ static struct mdio_device_id __maybe_unu
        { PHY_ID_MATCH_MODEL(PHY_ID_AQR105) },
        { PHY_ID_MATCH_MODEL(PHY_ID_AQR106) },
        { PHY_ID_MATCH_MODEL(PHY_ID_AQR107) },
index 107f2c4914cdd7624be2dfd7d1f79d6bef28294b..fddec74d9692f918b2e23313bcc01566067c4cec 100644 (file)
@@ -65,7 +65,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  /**
   *    ata_build_rw_tf - Build ATA taskfile for given read/write request
   *    @tf: Target ATA taskfile
-@@ -4517,6 +4530,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -4545,6 +4558,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
                if (tag < 0)
                        return NULL;
        }
@@ -75,7 +75,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
        qc = __ata_qc_from_tag(ap, tag);
        qc->tag = qc->hw_tag = tag;
-@@ -5295,6 +5311,9 @@ struct ata_port *ata_port_alloc(struct a
+@@ -5323,6 +5339,9 @@ struct ata_port *ata_port_alloc(struct a
        ap->stats.unhandled_irq = 1;
        ap->stats.idle_irq = 1;
  #endif
@@ -85,7 +85,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
        ata_sff_port_init(ap);
  
        return ap;
-@@ -5330,6 +5349,12 @@ static void ata_host_release(struct kref
+@@ -5358,6 +5377,12 @@ static void ata_host_release(struct kref
  
                kfree(ap->pmp_link);
                kfree(ap->slave_link);
@@ -98,7 +98,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
                kfree(ap);
                host->ports[i] = NULL;
        }
-@@ -5736,7 +5761,23 @@ int ata_host_register(struct ata_host *h
+@@ -5764,7 +5789,23 @@ int ata_host_register(struct ata_host *h
                host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
                host->ports[i]->local_port_no = i + 1;
        }
@@ -134,7 +134,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
  /*
   * Define if arch has non-standard setup.  This is a _PCI_ standard
-@@ -882,6 +885,12 @@ struct ata_port {
+@@ -883,6 +886,12 @@ struct ata_port {
  #ifdef CONFIG_ATA_ACPI
        struct ata_acpi_gtm     __acpi_init_gtm; /* use ata_acpi_init_gtm() */
  #endif
index 2751c9fe8882cd7bf7f4caf8d9d33a4635c7e3bc..e34891cbb6790488c081ff4ab079b574de7a0463 100644 (file)
@@ -15,7 +15,7 @@
        /* initialize internal qc */
        qc = __ata_qc_from_tag(ap, ATA_TAG_INTERNAL);
  
-@@ -4524,6 +4532,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -4552,6 +4560,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
        if (unlikely(ap->pflags & ATA_PFLAG_FROZEN))
                return NULL;
  
@@ -25,7 +25,7 @@
        /* libsas case */
        if (ap->flags & ATA_FLAG_SAS_HOST) {
                tag = ata_sas_allocate_tag(ap);
-@@ -4569,6 +4580,8 @@ void ata_qc_free(struct ata_queued_cmd *
+@@ -4597,6 +4608,8 @@ void ata_qc_free(struct ata_queued_cmd *
                qc->tag = ATA_TAG_POISON;
                if (ap->flags & ATA_FLAG_SAS_HOST)
                        ata_sas_free_tag(tag, ap);
@@ -36,7 +36,7 @@
  
 --- a/include/linux/libata.h
 +++ b/include/linux/libata.h
-@@ -911,6 +911,8 @@ struct ata_port_operations {
+@@ -912,6 +912,8 @@ struct ata_port_operations {
        enum ata_completion_errors (*qc_prep)(struct ata_queued_cmd *qc);
        unsigned int (*qc_issue)(struct ata_queued_cmd *qc);
        bool (*qc_fill_rtf)(struct ata_queued_cmd *qc);
@@ -45,7 +45,7 @@
  
        /*
         * Configuration and exception handling
-@@ -1001,6 +1003,9 @@ struct ata_port_operations {
+@@ -1002,6 +1004,9 @@ struct ata_port_operations {
        void (*phy_reset)(struct ata_port *ap);
        void (*eng_timeout)(struct ata_port *ap);
  
index 830440cf8dbf77c34068501a382bb8d2b6fa5e60..1ea8add32bf9458f376e4d04ecff782ae310e4d4 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/gpio/Kconfig
 +++ b/drivers/gpio/Kconfig
-@@ -514,6 +514,12 @@
+@@ -514,6 +514,12 @@ config GPIO_RTL8231
        help
          Say yes here to support Realtek RTL8231 GPIO expansion chips.
  
@@ -15,7 +15,7 @@
        depends on MFD_SYSCON
 --- a/drivers/gpio/Makefile
 +++ b/drivers/gpio/Makefile
-@@ -127,6 +127,7 @@
+@@ -127,6 +127,7 @@ obj-$(CONFIG_GPIO_RDC321X)         += gpio-rdc3
  obj-$(CONFIG_GPIO_REALTEK_OTTO)               += gpio-realtek-otto.o
  obj-$(CONFIG_GPIO_REG)                        += gpio-reg.o
  obj-$(CONFIG_GPIO_RTL8231)            += gpio-rtl8231.o
index 9a61a70c44d1760632f512c78f9ba11aabce30e4..d47e7bad504afcb5fb368c106c9e24ed98d01466 100644 (file)
@@ -1,15 +1,15 @@
 --- a/include/linux/phy.h
 +++ b/include/linux/phy.h
-@@ -93,6 +93,7 @@
-       PHY_INTERFACE_MODE_SMII,
+@@ -133,6 +133,7 @@ typedef enum {
        PHY_INTERFACE_MODE_XGMII,
+       PHY_INTERFACE_MODE_XLGMII,
        PHY_INTERFACE_MODE_MOCA,
 +      PHY_INTERFACE_MODE_HSGMII,
        PHY_INTERFACE_MODE_QSGMII,
        PHY_INTERFACE_MODE_TRGMII,
        PHY_INTERFACE_MODE_1000BASEX,
-@@ -163,6 +164,8 @@
-               return "xgmii";
+@@ -199,6 +200,8 @@ static inline const char *phy_modes(phy_
+               return "xlgmii";
        case PHY_INTERFACE_MODE_MOCA:
                return "moca";
 +      case PHY_INTERFACE_MODE_HSGMII:
index d36299d43b5cb8db56e7dde0ab0db8f4ce71563e..64e6b5d3094a4160bbce65be2ac0c4713af47e5b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/linux/phy.h
 +++ b/include/linux/phy.h
-@@ -226,7 +226,7 @@ static inline const char *phy_modes(phy_
+@@ -229,7 +229,7 @@ static inline const char *phy_modes(phy_
  #define PHY_INIT_TIMEOUT      100000
  #define PHY_FORCE_TIMEOUT     10