tools: xz: use .bz2 archive
authorJo-Philipp Wich <jo@mein.io>
Thu, 6 Oct 2016 10:25:29 +0000 (12:25 +0200)
committerJo-Philipp Wich <jo@mein.io>
Thu, 6 Oct 2016 12:12:45 +0000 (14:12 +0200)
In order to build XZ itself we cannot assume that XZ support is available,
so fetch the bz2 archive variant of its sources instead.

Also drop the FreeBSD portability patch and apply it at prepare time using
sed, to avoid a dependency on GNU patch which in turn depends on XZ support.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
tools/xz/Makefile
tools/xz/patches/100-freebsd-compat.patch [deleted file]

index 1bccbdb2632710143e46c3302b2caf5a3d526643..d08d6f899eb387f5be271767c1526cdadceb377f 100644 (file)
@@ -9,10 +9,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=xz
 PKG_VERSION:=5.2.2
 
 PKG_NAME:=xz
 PKG_VERSION:=5.2.2
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/lzmautils \
                http://tukaani.org/xz
 PKG_SOURCE_URL:=@SF/lzmautils \
                http://tukaani.org/xz
-PKG_MD5SUM:=f341b1906ebcdde291dd619399ae944600edc9193619dd0c0110a5f05bfcc89e
+PKG_MD5SUM:=6ff5f57a4b9167155e35e6da8b529de69270efb2b4cf3fbabf41a4ee793840b5
 
 HOST_BUILD_PARALLEL:=1
 
 
 HOST_BUILD_PARALLEL:=1
 
@@ -22,6 +22,14 @@ HOST_CONFIGURE_ARGS += \
        --enable-static=yes \
        --enable-shared=no \
 
        --enable-static=yes \
        --enable-shared=no \
 
+define Host/Prepare
+       $(call Host/Prepare/Default)
+
+       # FreeBSD portability fix
+       sed -i -e 's|#if defined(HAVE_BYTESWAP_H)|& \&\& !defined(__FreeBSD__)|' \
+               $(HOST_BUILD_DIR)/src/common/tuklib_integer.h
+endef
+
 define Host/Install
        +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat"
 endef
 define Host/Install
        +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat"
 endef
diff --git a/tools/xz/patches/100-freebsd-compat.patch b/tools/xz/patches/100-freebsd-compat.patch
deleted file mode 100644 (file)
index 480a652..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/common/tuklib_integer.h
-+++ b/src/common/tuklib_integer.h
-@@ -48,7 +48,7 @@
- // Operating system specific features //
- ////////////////////////////////////////
--#if defined(HAVE_BYTESWAP_H)
-+#if defined(HAVE_BYTESWAP_H) && !defined(__FreeBSD__)
-       // glibc, uClibc, dietlibc
- #     include <byteswap.h>
- #     ifdef HAVE_BSWAP_16